After installing Ubuntu 22.04, instead of the print test or any other print job, I get this on the paper:

URP Error
     Subsystem: PARSER
     Error: NotImplemented
     File Name: urp_urf_processor.c
     Line Number: 753

My printer model is a HPLaserJet M101-M106-IPP (wireless connection). Before installation of Ubuntu 22.04, it was fine both with Ubuntu 20.04 and Ubuntu 21.10. It still works fine with Windows 11, so I am only having the problem on Ubuntu 22.04.

  • 1
    I had found the decision at last. At a control page of CUPS (localhost:631), after changing PPD to "LaserJet M101-M106 - IPP Everywhere (grayscale)" driver I've got printer working.
    – Andrey
    May 7, 2022 at 15:55
  • You may post that as an answer. May 19, 2022 at 9:40
  • Yes it seems the issue is persistent after 22.04 update. It has reverberated downstream to other distros built on Ubuntu 22.04. The case applies to our HP-Lasterjet-mfp-129. We are connected through Wifi. the Error Code is VERBATIM to @Andrey. May 22, 2022 at 13:04
  • I have same issue on Fedora 36. It worked as expected on Fedora 35.
    – JiriHnidek
    Jun 8, 2022 at 14:18
  • I have used the Monochrome instead of the RGB in the Printer Options, which made it printing again...
    – eesdil
    Jun 10, 2022 at 14:29

3 Answers 3


Just select Monochrome in Print Color Mode instead of leaving it blank:

enter image description here

Or via file ~/.config/evince/print-settings containing only the following two lines:

[Print Settings]

The remaining lines of the file will be created during the first print job using Evince Document Viewer.

  • This works for printing PDFs but not libreoffice documents
    – wranvaud
    Jul 3 at 22:42

I am running Ubuntu 23.04 Daily and my printer printed the same error.

URP Error Subsystem: PARSER Error: NotImplemented File Name: urp_urf_processor.c Line Number: 753

I have Ubuntu 23.04 pre-relase. Printer: HP_LaserJet_MFP_M130nw_B90D11.

I solved this issue (temporarily) by setting the "Print Color Mode" to Monochrome in Settings -> Printer -> Printer Options.

Thanks for the solution!


For a complete solution I had to go to Settings > Printers > Additional printer settings > [Select printer] > Printer Options > Printer color mode > Monochrome.

This allowed me to print everything correctly including test pages, PDFs and libreoffice documents.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .