14

enter image description here

System information:

  • Intel Core i5-10600K
  • Gigabyte H510M H
  • NVIDIA GTX 1050TI 4GB
  • 500GB x1 NVME SSD (Installed Ubuntu), 2TB x1 HDD, 1TB x1 IDE HDD, and 250GB x1 SSD

Operating system:

  • Ubuntu 22.04
  • kernel 5.15.0-27-generic
4

3 Answers 3

5

For me the solution was exactly what the error message suggests: to enable SGX in BIOS. I have an HP Elitebook, in the BIOS Security section there is a checkbox:

  • Intel Software Guard Extension (SGX)

I set it to Enable (instead of Disable or Software defined)

1
  • Had the same with my Dell XPS 15. Thank you.
    – Daantje
    Jul 16 at 13:30
3

I had the same problem, but the SGX option literally did not exist in my BIOS, so it was impossible to change that.

A workaround was to reinstall with the "Minimal installation" option (as opposed to "Normal"), as well as not download updates or install third party software.

0

You can use this software to enable Intel SGX on Linux system Where the BIOS supports intel SGX.

I tried it, it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.