I installed 12.04 from CD in a partition where 8.?? had been working. The installation appeared fine but Ubuntu booted to a black screen. After updating packages and fighting with nvidia drivers for a while I now have a login screen.

If I log in using my password the screen goes black for a few seconds and then returns to the login screen. If I choose the guest session I get a black screen with a mouse pointer.

Ctrl+Alt+F1 works and I can log in, but many of the suggestions in previous answers either have no effect on the problem or fail with messages like:

Client failed to connect to the D-BUS daemon


X11 initialization failed

Is there a known way to get from here to a working system? I'd like to avoid reinstalling because my Internet connection is slow, and the original installation seemed OK.


Ensure that any files/folders in your user's home directory have correct permissions...

sudo chown -R user:user /home/user

That fixed it for me...


Remove the ~/.Xauthority -> https://askubuntu.com/a/289735/168033

  • Yes, that fixed it for me too (although I'm still getting intermittent errors). Thank you. – Rod Jun 2 '12 at 13:32

installing gnome-session-fallback then login in worked for me.

sudo apt-get install gnome-session-fallback

Maybe you could also try this:

These suggested instructions apply to my case only and should be considered as a non-professional comment and therefore to be tried AT YOUR OWN RISK.

I am using ACER Aspire 4755g with Ubuntu 12.04.1 LTS.

I have also encountered this problem, and in my case, I had a problem with lightdm. As a temporary measure, when you get to the login screen, press the keyboard sequence Ctrl+Alt+F1. This will get you to a terminal-like screen. It will show you something like this:


for example,

Aspire-4755g login:

type in your username and press Enter. This will result into something like this,

Aspire-4755g login: shiela


Enter your password, and, if correct, would show something like this:

Aspire-4755g login: shiela


Last login: Tue Jan 1 06:45:02 JPT 2013 on tty1

Welcome to Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-35-generic-pae i686)

* Documentation: https://help.ubuntu.com/

2 packages can be updated.

0 update are security updates.


Then, press the keyboard sequence Ctrl+Alt+F7 to get you back to the login screen. This procedure logs you into the system using the terminal-like window. You can now try to login to your account using the login screen. In my experience, I was able to reach the desktop. It seems that there is something wrong with the lightdm configuration that it was not able to log you in to the system.

Should you not make it to the desktop (as it was called in Windows), you may try adding an additional command by pressing the Ctrl+Alt+F1:

shiela@Aspire-4755g:~s ecryptfs-mount-private

press Enter, and it will ask you your password. Enter your password, then press the keyboard sequence Ctrl+Alt+F7 to get you back to the login screen (or to where you last left).

This command loads your Home folder, together with its contents, should you have chosen to encrypt the home folder upon installation of Ubuntu.

Once successful, you may try to review your lightdm configuration located on /etc/lightdm/lightdm.conf.

I have also written this suggestion in

Login screen loops unless you login as Guest


In my case, I had changed my password before I went on vacation about 12 days ago. My login password no longer matched my keyring password, therefore it was causing an error on login.

I did as others suggested above with the Ctrl-Alt-F1 and getting into a terminal window. I ran the following command:


It prompted for password - which I entered my new one, which was wrong - so then I entered my old one and it was fine. I switched back to Ctrl-Alt-F7 and logged in - once I logged in, my keyring prompted me for my password again.

Once all of this was done, I was back to my normal desktop. I am not sure if it will hold after a reboot or not. If not, I will look into ways of changing my keyring password to match my login password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.