3

I have installed Ubuntu 22.04. I enabled remote desktop in Settings -> Sharing -> Remote desktop -> Enable legacy VNC protocol. When connecting using Remmina to this machine, the session starts. The mouse moves and the keyboard sends keys, but the screen is black.

How to configure this remote desktop and VNC client?

  • When connecting Remmina 1.4.25 installed on Ubuntu 22.04 to local host, the screen works.

  • When connecting Remmina 1.4.11 installed on Raspbian to Ubuntu 22.04, the screen is black.

  • When connecting Remmina 1.4.25 installed on Ubuntu 22.04 to Raspbian, and then from Raspbian to Ubuntu, the screen works.

1
  • Strange, from unknown reason remote desktop works now. Commented May 4, 2022 at 5:03

3 Answers 3

1

Try changing the picture quality from the VNC client that you are connection from to something other than automatic. This is what fixed it for me.

You could also try this:

edit the /etc/gdm3/custom.conf file, uncomment WaylandEnable=false, and reboot in order to remotely access the login screen.

1
  • Thank for the pointers. Not used, because from unknown reason remote desktop works now. Commented May 4, 2022 at 5:06
1

Thanks for these instructions which worked after I also changed my RealVNC Viewer's Properties->Picture quality from "Automatic" to "High"

0

Screen Share Not working in Ubuntu 22.04 (In all platforms VNC, zoom, teams, google meet, anydesk, etc.,)

How to enable/disable Wayland on Ubuntu 22.04 step-by-step instructions

To check which display system your Ubuntu is using, please enter this command

echo $XDG_SESSION_TYPE

If the above command below mentioned output, your system is using Wayland.

wayland

In order to use screen sharing, we have to disable Wayland and enable Xorg (x11). To do this, Please edit to below file

sudo nano /etc/gdm3/custom.conf

Uncomment this below line.

WaylandEnable=false

Restart the UI service for the immediate effect of the above changes.

sudo systemctl restart gdm3

Voila! You can share your screen. You can confirm this by re-entering this command.

echo $XDG_SESSION_TYPE

If the above command below mentioned output, your system is using x11.

x11

After this follow the attached screenshot instruction

Step -1

Step -2

1
  • Deactivating Wayland may result in loosing keyboard and mouse. At least this is what happen to me. To get back input devices while deactivating Wayland I did sudo apt-get install --reinstall xserver-xorg-input-all Commented Apr 22 at 15:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .