I've recently upgraded to Ubuntu 22.04 LTS desktop version. Now, I feel everything runs slowly on my machine. For example, Firefox take 10 to 20 seconds to start up which used to take only 2 to 3 seconds in my previous Ubuntu (v. 20.04 LTS).

So, I decided to reinstall Ubuntu 22.04 by downloading the ISO from ubuntu.com; although everything is still the same. Firefox, terminal and most of the app run slowly. Doesn't matter which application I'm going to run as it's going to take 10 to 30 seconds. It's annoying actually. I don't know whether there is a problem with my machine or Ubuntu's new release. Some other apps that do not run with the same performance level and take too long to start (compared to Ubuntu 20.04 LTS desktop):

  • Telegram
  • Windscribe
  • VS Code

I have a core i3 CPU (3.8ghz 2 or 4 cores) + 8 gigabytes of ram (DDR4). I use no GPU and am fine with onboard GPU provided by CPU itself. I've got a solid state drive and an Asus h110 motherboard if that is related.

  • 6
    I've the same performance issue. Not only with the snaps(almost all native apps like files and terminal). 22.04 also boots too much slower than 20.04!
    – mohammads
    May 6, 2022 at 14:33
  • 4
    I can confirm that! found your question because I was lookin for solutions... also with chromium and chrome, web browsing is very slow, playing just a youtube video makes the browser and everything lag, thunderbird keeps boasting to 100% cpu and more here, running virtualbox and a simple ubuntu inside it makes doing everything else nearly impossible.
    – Henning
    May 13, 2022 at 19:27
  • 2
    I'm seeing this problem with the calculator and I've got a 16 core i9, this is ridiculous... I actually thought nothing was happening when I hit my "calc" key and then about a minute later FIVE calculators popped up.
    – Michael
    Jun 11, 2022 at 23:05
  • 1
    Ok, so I was seeing this problem as well, and initially I thought it was due to Ubuntu. In reality, in my case, it was related to this thread here, in which the CPU was locked at 200 MHz: community.frame.work/t/cpu-gets-stuck-at-0-2-ghz/16399. I suppose this might be happening for people who don't have Framework laptops as well. The solution in my case was to open up the case, unscrew the fan, blow around, and re-seat the memory. Not sure what if any of this fixed things. But Ubuntu started running at modern speeds again after that. Jul 11, 2022 at 0:40
  • 1
    Just a small comment: the swap space seemed to be the biggest problem for me. Initially, only 2GB was available (with 8GB of RAM), increasing it to 16GB solved the problem for me. Sep 23, 2022 at 8:11

3 Answers 3


As Henning already pointed out in his answer there is a bug ticked filed in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1973434. This ticket contains some suggestions what you could try to improve the sluggishness.

In my case (Thinkpad T480) the following two measures from the the ticket improved the responsiveness considerably:

  • in /etc/default/grub: Add the flag intel_iommu=off to GRUB_CMDLINE_LINUX_DEFAULT
  • Disable the Intel Turbo Boost: echo 1 | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo
  • 2
    Thank you very much! Minimal typo in last command. Should be echo 1 | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo
    – Mathias
    Jul 21, 2022 at 8:11
  • 1
    Thanks @Mathias, I fixed the typo Jul 21, 2022 at 8:18
  • 1
    I don't know if related but upgrading to 22.04.01 also seems to have improved the situation Aug 9, 2022 at 11:04
  • 1
    I updated from 20.04 to 22.04.1 and the system was trash! After setting intel_iommu=off and rebooting, everything was snappier! Aug 17, 2022 at 8:19
  • 1
    @MichaelOsl , in my case it did not, I was running 22.04 just fine. Upgrading to 22.04.1 messed up the performance . As soon as I start the machine, even if most of the external service are off loaded from auto start, load average is 6 and everything is just so slow.
    – 89n3ur0n
    Aug 29, 2022 at 17:47

I trial and errored a while and somehow got the idea it is a kernel thing, as it all somehow feels like wrong scheduling or something like that.

So I ended building myself a current mainline kernel 5.17.7 from https://www.kernel.org/ by taking the config file from my last 21.10 ubuntu standard kernel, running oldconfig, confirming all defaults. Oh and removing the ubuntu keys part manually...

And so that seems to work, I can play as many youtube videos as i wish, have a virtualbox vm running, look at my mails in thunderbird, browse the web with firefox (videos where in chrome) and nothing hangs as before.

Filed a bug and there is another proposed solution, along with the outlook this will be fixed in a later release, but can take a while: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1973434

Additional hint:

For those who didnt build a kernel on their own so far, that task will require quite some learning and time, so the preferred thing to try is the workaround described on launchpad. The adventurous might check the Kernel documentation https://docs.kernel.org/, the UBuntu Wiki on Kernel building https://wiki.ubuntu.com/Kernel/BuildYourOwnKernel and this necessary fix on the mainline Kernel in Ubuntu when using "oldconfig": Compiling the kernel 5.11.11

  • Could you add a bit more detail? I don't think your answer as it stands will help people much.
    – Will
    May 16, 2022 at 21:03
  • 1
    for the information contained therein would have saved two days of experimentation. I understand this will not help people with any experience level, but only those slightly experiuemced with building a kernel, but I cannot give a ful kernel comile tutorial here. I tried to add some hints on where to learn more about that.
    – Henning
    May 20, 2022 at 15:38
  • 1
    thanks for adding that!
    – Will
    May 22, 2022 at 12:11
  • 1
    @Michael right now it is very unclear where all these things really come from... it can be a very low level Kernel bug, it can be a broken Thinkpad ACPI Implementation, or a bug in the power-profile-daemon.... or a crazy combination of thzese
    – Henning
    Jun 16, 2022 at 16:11
  • 2
    I can confirm that the extreme slowness is not specific to ThinkPads, as I'm running a Framework laptop, and Ubuntu 22.04 Desktop installed from an iso is unusable. Jul 10, 2022 at 17:36

I have been running Variety to change my desktop wallpaper for years. I recently changed it to only change the wallpaper on startup. The upgrade to 22.04 slowed my machine(s) to almost worthless - (a really old desktop, laptop and a rescued iMac all from about 2007 and all with 4GB RAM). I recently ran the system monitor for a couple hours while watching the ball game. WOW! What a surprise... Variety was constantly pinging the Internet and sucking up CPU, at around 25%. I shut Variety down and the difference is amazing. If you are using Variety, kill it as soon as it changes your wallpaper or replace it with a different background engine. GTH

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .