34

The default video player (Totem) is unable to play videos after installing Ubuntu 22.04. I tried opening an MP4 file and I get the error (also shown in the screenshot):

An error occured

The specified movie could not be found.

error in default video player

I also tried installing ubuntu-restricted-extras, but it's still not working.

2
  • 1
    @user2983060 Try seeing if VLC can play the video. It can play almost anything. I really mean it - it is designed to play almost anything, even files 'normal' video players can't
    – cocomac
    May 3 at 5:26
  • 1
    Hi @cocomac, thanks buddy, VLC is working fine but what's wrong with the default video player?
    – Balakumar
    May 3 at 5:41

2 Answers 2

42

This is a known issue for Ubuntu 22.04: Ubuntu 22.04 - totem 41.alpha.0 - The specified movie could not be found

There are also bug reports on Launchpad about it, which I suggest you subscribe to, so that they get more heat and hopefully get dealt with more quickly:

The workaround for the moment is to either use the Flatpak version of Totem or another video player, such as VLC, mpv, etc.

Update 23/05/2022:

As Samuel Simon commented in 19/05/2022 in the first bug report above:

Run this command:

sudo apt remove gstreamer1.0-vaapi

Got my solution from this article, check it out too. https://www.makeuseof.com/things-to-do-after-upgrading-to-ubuntu-2204-lts/

Thanks @Manuel for mentioning this workaround in their answer.

4
  • 1
    sudo apt remove gstreamer1.0-vaapi saved my day. Thank you!
    – GhitaB
    Oct 16 at 23:17
  • 1
    Thank you! Removing gstreamer1.0-vaapi immediately fixed the problem.
    – Gael
    Oct 17 at 7:50
  • 1
    sudo apt remove gstreamer1.0-vaapi did not work for me. My problem still persists. Nov 8 at 15:59
  • I installed totem via flathub. Videos tatred playing iside Totem, My problem was that videos embedded in beamer latex presentation were not playing. Installing VLC did not help as videos in beamer still could not play inside it. Later on I tried this sudo apt install ubuntu-restricted-extras from this youtube video youtu.be/t0sgtQXyNJQ. Videos work now when clicked, but they open in a different window. Well something is better than nothing. Nov 8 at 16:53
26

As pointed in the second link of the answer given by @BeastOfCaerbannog, a solution for PCs (no Raspberry Pi, as pointed in the same thread) is to remove gstreamer1.0-vaapi:

sudo apt remove gstreamer1.0-vaapi

Here is the original article.

4
  • This didn't work for me. My mp4 videos played for a bit and then hung, with the sound continuing! The snap version of vlc didn't work either; it never appeared to start. What worked for me in the end was sudo apt install vlc (see askubuntu.com/a/1412874/103266)
    – snark
    Sep 19 at 10:54
  • Forgot to say: then make VLC Media Player your default application for videos in ubuntu's settings; otherwise Videos will keep trying to run when you double-click on mp4 files.
    – snark
    Sep 19 at 11:09
  • I think that it will be valuable for other people if you write your commented solution as an answer
    – Manuel
    Sep 20 at 11:53
  • Maybe. It follows on directly from yours since I tried your answer first and then didn't undo it. Maybe if I had undone your suggestion first a different approach would've worked.
    – snark
    Sep 21 at 13:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.