Recently upgraded to Ubuntu 22.04, and it seems like the power-saving feature does not actually turn off the screen(s) after X minutes, but just blanks them. When I manually run xset dpms force off, they do properly turn off and go to sleep, but this and related solutions (e.g. https://askubuntu.com/a/1004163/29252) do feel rather kludgy.

Any suggestions for how to fix this "properly"?

  • 2
    Also reported as bug: bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/… (not 100% sure if g-s-d is the right component, though). May 3, 2022 at 14:24
  • Added an affect me to your launchpad bug report
    – papampi
    May 6, 2022 at 20:17
  • The screens won't turn off when the Power Profile is set to "Performance". They turn off when it is "Balanced" or "Power Saver". May 8 at 0:09
  • A workaround that seems to work for me: after login, lock the screens once manually using Super-L. After that, powersave works as intended. Aug 18 at 6:46
  • sometimes its the wrong displaymanager (gdm3, lightdm, slim, sddm, ...). If there is only one working (is it?) try "sudo dpkg-reconfigure gdm3" and confirm gdm3 (which is needed for Gnome based screensaver functionality). Oct 2 at 18:08

1 Answer 1


I detected the issue in my system. Since I'm using a desktop, I managed to solve the problem by replacing the HDMI cable with a DisplayPort cable. Now, my monitor completely turns off. I hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .