2

after reading askubuntu as a guest for some time I decided to be an active part of the community posting here my first question.

I bought an HDD of 2TB some months ago. It worked ok, but when I was switching to exchange files between Windows 10 and Ubuntu 20.04 it was not working perfectly. Anyway I ignore that as I kind of made it work.

Today I tried to backup my Windows files in the HDD as I barely use that partition and it is using a lot of space. When I plug my HDD, Windows suggest the repair disk because there was some error in the HDD. I clicked yes and after 15 minutes of running the repair disk tool, It suggested me to format the disk as it was damaged. I did not format it and reboot my PC with Ubuntu (I am running dual OS Win10 original and Ubuntu 20.04).

After that my HDD is not auto playing anymore when I plug it, Windows does not recognize it and I have the following outputs in Ubuntu after trying some troubleshooting

~$ sudo fdisk -l

Output only for disk sdb

*Disk /dev/sdb: 1,92 TiB, 2086666240000 bytes, 4075520000 sectors
Disk model: UDisk           
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes*

~$ lsblk

*sda      8:0    0 238,5G  0 disk 
├─sda1   8:1    0   260M  0 part /boot/efi
├─sda2   8:2    0    16M  0 part 
├─sda3   8:3    0 178,8G  0 part 
├─sda4   8:4    0   800M  0 part 
├─sda5   8:5    0   1,9G  0 part 
├─sda6   8:6    0  47,5G  0 part /
└─sda7   8:7    0   3,8G  0 part 
sdb      8:16   0   1,9T  0 disk* 

~$ sudo parted -l

*

Model: ATA HFS256G39TND-N21 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 
Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  274MB  273MB   fat32           EFI system partition          boot, esp
 2      274MB   290MB  16,8MB                  Microsoft reserved partition  msftres
 3      290MB   192GB  192GB   ntfs            Basic data partition          msftdata
 5      192GB   194GB  2048MB  ext4
 6      194GB   245GB  51,0GB  ext4
 7      245GB   249GB  4048MB  linux-swap(v1)                                swap
 4      255GB   256GB  839MB   ntfs            Basic data partition          hidden, diag
Error: /dev/sdb: unrecognised disk label
Model: General UDisk (scsi)                                               
Disk /dev/sdb: 2087GB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags:

~$ sudo mount /dev/sdb /mnt

mount: /mnt: wrong fs type, bad option, bad superblock on /dev/sdb, missing codepage or helper program, or other error.

I try opening gparted: ~$ sudo gparted /dev/sdb and the disk is unallocated and unrecognised disk label.

At some point I visualize that the type of disk is dos, but I dont see that output anymore

I have some data that I want to save in the disk but I am also open to format the disk if it is impossible to recover the data.

Any help is welcome.

1

1 Answer 1

-1

1- WARNING! THIS WILL ERASE YOUR DISK >>> (sdb, 2TB)

fdisk /dev/sdb

first, you need to delete. press d. then, press n, select primary (press p), select space number (select 1), enter, +1.9T enter. press w

2-

mkfs --type ext4 /dev/sdb1

if you get any error at this stage, you need to control file system

file -s /dev/sdb1

if there is a filesystem for sdb1, you have to delete it. after deleting it, run the mkfs command

wipefs -a /dev/sdb1

3-

mkdir /media/2TB1

4-a (temp way, you will have to do this after your new logins)

mount /dev/sdb1 /media/2TB1

4-b (perm way. do just once)

sudo nano /etc/fstab

add this line to the file, then press ctrl+O enter and ctrl+x

/dev/sdb1 /media/2TB1 ext4 defaults 0 0

type

mount -a

now, you can use your 2TB disk in ubuntu. if your aim is not formatting your disk, please let me know. we may road another way for you.

6
  • 1
    HI helloubuntu, thanks a lot for your quick answer. If it is possible I would like to recover my data and then formatting my disk. Then I would like to use my HDD with Windows users sometimes so dont know if ext4 is the best format for my disk. NTFS should be the right one for windows, or may be making one partition with 1TB NTFS for windows and 1TB ext4 for linux, not sure, What do you think? Commented May 1, 2022 at 17:31
  • you're welcome. Commented May 1, 2022 at 17:32
  • dont know if you read my last update, just drop you a message just in case. thanks again Commented May 1, 2022 at 17:47
  • I have just seen your update. you can create a partition for 1TB. Thats okay. you can create 2 partitions, 1 for linux, 1 for windows. that's not the problem. the problem is recovering your existing data. please give me some minutes to run some tests on my virtual debian os Commented May 1, 2022 at 17:58
  • have you ever tried testdisk command? I have never tried it. It might be the solution to recover your existing data. I need to test it on my virtual debian os.. need some time Commented May 1, 2022 at 18:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .