24

Before opening a bug I would like to know if anyone else has the following Update from 18.04 to 22.04 with exactly the same hardware, nvidia GTX 1050ti graphics card and same monitor, while in 18.04 the colors are correct in 22.04 everything has a pinkish tint even the whites and grays

It's very easy to test, check this shade of gray in both versions, while at 18.04 it shows as perfect gray at 22.04 it will look pinkish

https://imagecolorpicker.com/color-code/ebebeb

I don't know if it could be an error of the color profiles that comes by default, but even deactivating them it happens, maybe it has to do with the yaru theme? Anyone else with the same problem?

2
  • 2
    Go to gnome-control-center (Gnome Settings) → Color → Laptop Screen and remove the selected profile. Try other profiles.
    – FedKad
    May 1, 2022 at 10:25
  • Thanks..., I couldn't find a way to change the profile and it really is very simple
    – Mario
    May 1, 2022 at 13:39

3 Answers 3

44

Problem solved..., thanks to FedKad..., with the default color profile everything has a pink tint changing the color profile to sRGB the problem is solved

Go to Settings - Color - Add Color Profile and select an sRGB

6
  • 4
    Thanks. Note that I had to delete the default profile before being able to add a new one. May 8, 2022 at 18:22
  • Thanks! I had to change from "Automatic - Precision 5510" to "Automatic - Precision 5540".
    – kelunik
    May 17, 2022 at 14:19
  • Experienced an over saturated screen on a Bosto Tablet and this helped! Had to first Delete the Profile, after which adding the Standard Space - sRGB profile solved it on Ubuntu 22.04 Aug 24, 2022 at 15:53
  • As a colorblind person it took me a while to blame the distro! :) Aug 30, 2022 at 8:55
  • 1
    You saved my life, thankyou!
    – think01
    Jan 4, 2023 at 16:13
3

This really worked for me. I bought a Dell 9720 and installed Ubuntu on it. I could make everything work fine but the pinkish colors were really bothering me. So, I set up a color space compatible with Adobe RGB(this one is best suited for Dell 9720). And now everything looks fine.

Go to Settings - Color - Add Color Profile and select Adobe RGB.

Thanks for the comment

1

After upgrading to ubuntu 22.04 everything worked fine with the latest drivers but I couldn't share my screen because of wayland so I switch back to xorg.I then got the funny colors so I downgraded to 20.04 only to have same problem. Turn out switching to nvidia drivers 470 in both versions seems to fix the issue.

1
  • Installing nvidia drivers instead of xorg fixes the red colors, I can confirm.
    – hb0
    Jun 30, 2023 at 14:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .