1

Timedoctor2 is not opening. It crashes with the following error output:

Timedoctor2 error output

[Main] ERROR sfproc.webview - The render process was terminated "satusCode = 159 " "status = \"Crashed\" " "url = QUrl(\"\") "
1
  • 1
    I heard back from their support that it's not currently supported on Ubuntu 22.04. They say that they're working on it though. May 4, 2022 at 9:43

4 Answers 4

6

Try to run in the terminal:

export QTWEBENGINE_DISABLE_SANDBOX=1

And open the time running:

~/timedoctor2/timedoctor2
1
  • 1
    What does this do and why does it help? Can you edit your question to add some more details and help future visitors be able to recognize if this answer is correct?
    – Esther
    Jun 2, 2022 at 17:53
0

Please remove the check above Use system proxy. This works for me.

0
0

These steps worked for me in Ubuntu 22.04:

  1. Exit from the top right corner by right-clicking.

  2. From a terminal run:

    export QTWEBENGINE_DISABLE_SANDBOX=1
    
  3. From a terminal run:

    timedoctor2
    

    and keep the terminal running.

0
  1. Once installation finished, exit timedoctor
  2. Edit below file in your favorite editor

vim ~/.local/share/applications/timedoctor2.desktop

  1. Modify exec parameter and add below environment variable

exec=env QTWEBENGINE_DISABLE_SANDBOX=1 env QTWEBENGINE_DISABLE_SANDBOX=1 /home/HOME_DIR/timedoctor2/timedoctor2

  1. Edited file looks like below.
[Desktop Entry]
Type=Application
Version=0.9.4
Name=Time Doctor 2
Comment=Run Time Doctor 2
Icon=/home/HOME_DIR/timedoctor2/timedoctor2.png
Exec=env QTWEBENGINE_DISABLE_SANDBOX=1 /home/HOME_DIR/timedoctor2/timedoctor2
Terminal=false
Path=/home/HOME_DIR/timedoctor2
Categories=Development

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .