I upgraded to 22.04 and now encfs segfaults when I try to mount my encrypted directory (which had been in use for many years now)

  • What exact command are you running that triggers the segfault? Also, does the segfault have any (useful) error message? Side note: the last commit on that project was May 2020. Per the repo, the project is dormant, it has been deemed insecure, and development has been halted. So... there may not be a solution. To recover the data, you could try booting a 20.04/21.10 live CD, and using that to recover the data, and then move to some other way to encrypt your files
    – cocomac
    Apr 30, 2022 at 4:26
  • (continued) Please note that live CDs are not persistent (they get wiped on reboot), so if you recover the data that way, please do not save the files to the live CD. Cloud storage (OneDrive, Google Drive) is a short-term option, or an external hard drive would do. But don't save them to the live CD. If you have tons of data (several TBs or more) consider using Backblaze B2 instead (no affiliation, but I've heard good things about it).
    – cocomac
    Apr 30, 2022 at 4:29
  • It segfaulted after entering the password. I mounted a backup USB disk on a laptop still running 20.04 which worked fine and transferred the unencrypted data by sftp. It appears that creating a new encfs, which uses a newer format for the config file, works. Some incompatibly with the older format seems to have been introduced even though it's not a real new version of the program. Since it's poorly regarded I'll just stop using it but it was a big surprise to suddenly have a data-recovery project!
    – Michaela P
    May 1, 2022 at 13:53

1 Answer 1


Also ran into this, and was able to move forward by following the advice at https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1014193

In /etc/ssl/openssl.conf make sure you have these sections:

providers = provider_sect
default = default_sect
legacy = legacy_sect

activate = 1
activate = 1
  • I tried Karol's answer of modifying /etc/ssl/openssl.conf and adding a legacy_sect, but I was then unable to log in to my machine via the gui! Fortunately I was able to get a TTY with Ctrl-Alt-F2 and revert the changes to the ssl config file. Dec 18, 2022 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.