5

I recently upgraded to 22.04 from 21.10.

And now I can't control volume level for my Bluetooth headset. I can only mute it or it plays at full volume(regardless of the volume selected).

It didn't happen in earlier version.

I can control volume level correctly when playing audio through laptop speakers.

3 Answers 3

5

Disable absolute volume in Pulseaudio's config.

Edit the file

/etc/pulse/default.pa

And change the line

load-module module-bluetooth-discover

to

load-module module-bluetooth-discover avrcp_absolute_volume=false

Credit for this solution goes to https://www.reddit.com/user/mmstick/ https://www.reddit.com/r/pop_os/comments/s2y0hf/pop_os_2110_brake_bluetooth_device_volume_control/

4
  • 1
    Worked for me after sudo service bluetooth restart.
    – Reece
    Aug 23, 2022 at 4:12
  • This doesnʼt work for me directly (pipewire not Pulse, because Iʼm not actually on Ubuntu) but it definitely got me started on the right track. Thanks!
    – Daniel H
    Feb 11, 2023 at 3:54
  • a slight annoyance i'd like to note is that while this does work on Kubuntu 22.04 controlling the volume via the bluetooth headphones buttons doesn't pop up the volume change overlay, it still changes the volume it's just harder to see at a glance what volume level it's at
    – askcompu
    Oct 18, 2023 at 22:38
  • Can I set this separately per device? Nov 14, 2023 at 20:51
0

I have the same volume level issue while playing anything via bluetooth, but replacing the load-module module-bluetooth-discover didn't work for me.

When playing a youtube video (for example), every time that I want to change the volume level, I have to go into the settings and change it on Volume Levels > Chromium (it also happens with Chrome).

sound settings - browser

The same happens when using a player like VLC:

sound settings - VLC player

System:

  • Ubuntu 22.04
  • Pulse Audio version: 15.99.1

results from lspci -v | grep -A7 -i "audio":

00:1f.3 Audio device: Intel Corporation Cannon Point-LP High Definition Audio Controller (rev 30) (prog-if 80)
    Subsystem: Lenovo Cannon Point-LP High Definition Audio Controller
    Flags: bus master, fast devsel, latency 32, IRQ 140
    Memory at a4318000 (64-bit, non-prefetchable) [size=16K]
    Memory at a4000000 (64-bit, non-prefetchable) [size=1M]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel, snd_sof_pci_intel_cnl

Any ideas on how to fix it?

1
0

After trying different solutions, this is what worked for me:

  1. Open the file /etc/systemd/system/bluetooth.target.wants/bluetooth.service

  2. Change this line: ExecStart=/usr/lib/bluetooth/bluetoothd to ExecStart=/usr/lib/bluetooth/bluetoothd --plugin=a2dp

  3. Restart the services with sudo systemctl daemon-reload and sudo systemctl restart bluetooth


Taken from here [1].


  [1]: https://askubuntu.com/a/1350436/1151893

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .