26

I have just installed Ubuntu 22.04 LTS. It works fine but after I suspend the session, the screen remains black after restarting the session.

How can I solve it?

Thanks

8 Answers 8

20

Got an update from the launchpad. There is a work around for Nividia 510 using the solution from Nividia 470.

Disable NVIDIA systemd services

sudo systemctl stop nvidia-suspend.service
sudo systemctl stop nvidia-hibernate.service
sudo systemctl stop nvidia-resume.service

sudo systemctl disable nvidia-suspend.service
sudo systemctl disable nvidia-hibernate.service
sudo systemctl disable nvidia-resume.service

Remove NVIDIA systemd script

sudo rm /lib/systemd/system-sleep/nvidia

Reboot and you should be able to suspend and resume properly with driver 510 for 22.04 for both x11 and wayland

The original workaround was for 470. However, I've tested it and the solution works for 510 on 22.04 with x11 and wayland.

Original solution with details can be found here by contributor "humblebee". And bug report on launchpad can be found here

11
  • 2
    But is the OP actually using an NVidia driver? And just be a little wary of using 'copy and paste' answers: askubuntu.com/a/1406212/57576
    – andrew.46
    May 2, 2022 at 22:53
  • This did not help me. I tried with 515, 510, 470 versions (Xorg and Wayland). For all I tried above steps. Worked fine with previous Ubuntu versions.
    – Alexey Vol
    Jul 13, 2022 at 11:49
  • Thanks! Worked for me (470, GTX 660, Old MSI MB, B75MA-P45). Note: I tried forcing GDM to use XOrg first, so I've only tested on a XOrg only system.
    – olejorgenb
    Oct 2, 2022 at 10:24
  • This works for Ubuntu 22.04 + Nvidia 515 drivers on my workstation.
    – faceclean
    Oct 17, 2022 at 5:22
  • This does not help me for both 470 and 510. My card is 1660ti. Ubuntu 22.04 Oct 21, 2022 at 8:26
3

In may case downgrading nvidia driver from 510 to 470, via Additional Drivers , solved the issue

2

It's more of a workaround, but i am able to resume the GUI session after a black screen caused by a suspend by switching to a virtual console (ctrl+alt+F1 to F7 depending on your computer) and then reverting to GUI session (ctrl+alt+FX, again, the FX depending of your computer, F2 for me).

Works for me with nvidia driver 515 and cuda 11.7

1

I was having this exact same problem on my HP Pavilion 14 on Ubuntu 22.04. It worked fine a few days ago but I encountered this problem after an update. Lots of stack answers pointed to some problems with Nvidia drivers, but I don't have Nvidia graphics. I have an integrated AMD Radeon along with AMD Ryzen 7.

What worked for me:

Installing amdgpu-install and installing the AMD graphic cards components[1] after checking the secure boot support[2]:

amdgpu-install --usecase=graphics

Also, check this launchpad issue[3].

[1]https://amdgpu-install.readthedocs.io/en/latest/install-overview.html

[2]https://amdgpu-install.readthedocs.io/en/latest/install-installing.html#ubuntu-and-debian-based-systems

[3]https://bugs.launchpad.net/ubuntu/+source/linux-signed-hwe-5.19/+bug/2008774

0

-Changing graphics card driver, "nvidia driver 515 tested" worked for me

0

Upgrading Nvidia Driver to version 525 solved this problem for me on Ubuntu 22.04 with graphic card model GeForce GTX 1060 (via "Software & Updates"). Note that a user of Linux Mint with the same graphic card had the same problem 10 months ago.

0

I'm using AMD CPU, and after wakeup, the screen keeps blank.

I fixed it by pressing Ctrl + Alt + F1.

Sometimes I have to keep pressing Ctrl + Alt + F1, but once it gives output to the screen, if I suspend the PC again, it will automatically wake up with the display output properly.

[update]

Finally, I found a permanent solution, and the problem is HDMI. If I connect it to a VGA cable, the screen lights up as normal.

[update]

It seems my monitor is missing the proper information to wake up from the PC, so I tried to change my HDMI cable, and yes, it works. Before, I was using a cheap $1.7 HDMI cable.

0

In my case, none of the other suggestions about drivers worked. The only thing that fixes the problem is logging in to Ubuntu on Xorg.

Ubuntu on Xorg

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .