33

In both

  • MS Teams (Microsoft Teams Version 1.5.00.10453 (64-bit)) and
  • Zoom (Version: 5.10.4 (2845))

on Ubuntu 22.04 LTS (42.0, Wayland) no screen shows up after clicking on "share screen".

Hardware: Lenovo ThinkPad X1 Yoga 3rd, Mesa Intel® UHD Graphics 620 (KBL GT2), Intel® Core™ i7-8550U CPU @ 1.80GHz × 8 connected with two monitors via Thinkpad Thunderbolt 3 dock.

Is there a configuration issue, or is screen sharing not supported?

6
  • 4
    Going back to Xorg which is regularly proposed as a solution to the above problem is pretty much like telling someone to ditch their car and go back to horse and carriage if they have a flat tire. One of the reasons screen-sharing works under X and not under Wayland is that X has no concept of security. Every X application has full access to the frame buffer and thus sees everything. Disabling security -- however crude a solution that may be -- does the trick for now and you are not worse off than with Xorg and at least you can disable it for the duration of your screen sharing session only.
    – momesana
    May 23, 2022 at 9:01
  • Finally some common sense. I think the best solution for now is just to use Zoom from the browser (and complain to Zoom that this is ridiculous, Ubuntu 22.04 is recent but Wayland has been around for years now). Note: to make screen sharing work in Chrome it's sufficient to enable WebRTC PipeWire support in chrome://flags.
    – korg91
    Jun 22, 2022 at 14:56
  • It would be good if these were two separate question posts, as the solution for Zoom may not be the same as the solution for Microsoft Teams.
    – Flimm
    Jul 20, 2022 at 8:43
  • 1
    Newer versions of Zoom seem to have fixed this.
    – Flimm
    Jul 20, 2022 at 8:45
  • This isn't an answer as it doesn't tell you how to do something useful (screen sharing) that every other OS, which also have security models for their windowing systems, allows without issue.
    – siride
    Aug 13, 2022 at 17:35

5 Answers 5

22

These applications have not been updated for Wayland, which is why screensharing does not anymore work for the time being.

You may want to switch to Xorg to regain this functionality. To do so, log out, then, before entering your password, click the cog on the bottom right and log in on "Ubuntu on Xorg".

Other workarounds include relaxing security settings in Gnome Shell or using a browser based version of Zoom in a browser that supports Wayland.

4
  • 1
    Thank you! Simple solution, after switching to "Ubuntu on Xorg", screens can be shared in both MS Teams and Zoom. Apr 28, 2022 at 8:46
  • 1
    You can disable Wayland's safe mode by pressing ALT+F2, type lg and do global.context.unsafe_mode=true. I've written a small Gnome Extension which does this for you: github.com/julianpollmann/zoom-wayland-gnome-extension
    – polyte
    May 13, 2022 at 12:11
  • I particularly liked the second solution. Is there something similar on KDE?
    – Bruni
    May 20, 2022 at 6:39
  • 2
    how the hell you quick that command prompt (lg) ?
    – Antonello
    Nov 3, 2022 at 14:22
10

Screen sharing is disabled as Ubuntu starting from version 21.04 started depending on Wayland instead of xorg.

To fix this issue easily:

a. To login with xorg for user session:

  1. before login there's a setting icon on the bottom left, click on it and choose Ubuntu

b. To disable Wayland and use xorg only:

  1. Open your terminal and write sudoedit /etc/gdm3/custom.conf

  2. Uncomment the value waylandEnabled=false -- just remove the #

  3. Press Ctrl+O then Enter then Ctrl+X

  4. Reboot your computer.

This will trigger Ubuntu to fall back to Xorg and then you can share the screen again.

When rebooting you need to manually select the "Ubuntu with xorg" at the login screen. At the bottom right of the screen there should be a gear. Click on it to select the x11 version.

1
  • 1
    No need to change /etc/gdm3/custom.conf. It is sufficient to log in on Xorg (last two lines of this post).
    – vanadium
    Sep 9, 2022 at 8:20
2

Other answers disabling Wayland works, but for anyone for which dropping Wayland just to enable screensharing isn't an option:

the ms teams web client does work in Ubuntu 22.04.

3
  • Doesn't work for me. I've tried both the desktop and web client. Nov 29, 2022 at 12:13
  • Confirm that it works in Edge browser
    – Rapekas
    Feb 21, 2023 at 4:19
  • Does not work for me without disabling wayland.
    – user48956
    Sep 25, 2023 at 18:36
1

I got the same issue I was able to solve it from below approach

  1. Log out from your current account.
  2. You will get a setting icon in bottom-left corner
  3. Tap on setting icon
  4. Select Ubuntu xorg
  5. Now Login in again and try to share screen. Hope it's works.
0

It's working now with the Microsoft teams progressive web apps PWA. I think the issue was with only desktop apps.

Check this out: https://www.microsoft.com/en-us/microsoft-teams/download-app

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .