2

I just upgraded to Ubuntu 22.04 (from 20.04). It's pretty good but I have some problems.

I want my shortcuts to be as follows:

  • Switch to workspace left: <Control><Alt>Left
  • Switch to workspace right: <Control><Alt>Right
  • Move window to workspace left: <Control><Shift><Alt>Left
  • Move window to workspace right: <Control><Shift><Alt>Right

These are pretty standard, it was like that on my previous install (but with Up and Down, since the workspaces were arranged vertically).

I could set the first two in Settings, and they work, but I can't set the last two. For some reason it just won't capture my key combination. So I decided to set them in dconf-editor (in org.gnome.desktop.wm.keybindings), but then it just doesn`t work when I try to use them (sometimes it just switches the workspace in the right direction without moving the window, other times it doesn't do anything at all, seemingly randomly).

Am I doing something wrong or is this a bug? If it's a bug, is there a workaround to get what I want?

0

1 Answer 1

5

I found the problem. During the upgrade, I vaguely remember a dialogue asking me how I want to switch keyboard layouts and I was happy to see that the Alt+Shift option was back, so I selected it (I tried setting up that hotkey on 20.04, but I just couldn't get it to work).

However, it seems that this is what was interfering with my desired hotkeys for moving windows between workspaces, including why I couldn't set it up in the Settings application.

To disable it, I used gnome-tweaks by going to "Keyboard & Mouse" > "Additional Layout Options" > "Switching to another layout" and I unchecked the "Alt+Shift" option.

While I am happy that I can use my normal shortcuts to move windows between workspaces, I regret that I still can't use the Alt+Shift option to switch between keyboard layouts. If anyone knows how I could make that work, can you let me know?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .