3

When upgrade my linux to 22.04 and openssl3.0.2 (php7.4-fpm) get this error in my site:

file_get_contents(): SSL operation failed with code 1. OpenSSL Error messages: error:0A000126:SSL routines::unexpected eof while reading
2

1 Answer 1

3

How about enabling the Legacy provider?

I saw a similar trouble with Nextcloud on Ubuntu 22.04 and finally I avoid it with this change.

https://gist.github.com/rdh27785/97210d439a280063bd768006450c435d

2
  • It would be nice if you could explain what to do a little bit more in the post rather than relying so heavily on a link
    – Zanna
    May 5 at 8:38
  • 1
    > It would be nice if you could explain what to do a little bit more in the post rather than relying so heavily on a link Thank you for your suggestion. My gist is a patch for /etc/ssl/openssl.cnf, to enable the compatible algorithms of OpenSSL. The algorithms are called "The legacy providers". These are weak but I think this setting is useful for surpassing the current situation. See also: github.com/openssl/openssl/blob/master/README-PROVIDERS.md May 6 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.