4

I am trying to connect to my PC (Kubuntu 21.10 - kernel: 5.13.0-40) a Baofeng UV-5r transponder using Chirp SW with a USB-serial cable:
Bus 002 Device 005: ID 1a86:7523 QinHeng Electronics CH340 serial converter

but I receive the following error message:

[Errno 13] could not open port /dev/ttyUSB0:[Errno 13] Permission denied: '/dev/ttyUSB0'

I have checked the CH340 device driver and it is seems to be loaded in the kernel:

ID 1d6b:0002 Linux Foundation 2.0 root hub  
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M  
ID 8087:0024 Intel Corp. Integrated Rate Matching Hub  
|__ Port 1: Dev 4, If 0, Class=Vendor Specific Class, **Driver=ch341**, 12M  
ID 1a86:7523 QinHeng Electronics CH340 serial converter

Here is the list of ttyUSB dev files (/dev)

crw-rw---- 1 root dialout 188, 1 apr 26 16:08 ttyUSB1  
crw-rw---- 1 root dialout 188, 2 apr 26 16:08 ttyUSB2  
crw-rw---- 1 root dialout 188, 3 apr 26 16:26 ttyUSB3

(user belongs to dialout group)

4
  • 1
    Have you tried adding your user to the dialout group ?
    – Soren A
    Apr 26, 2022 at 17:05
  • 2
    Did you logout/login after adding yourself to the dialout group? Check with id. Groups are set up in the login process.
    – waltinator
    Apr 26, 2022 at 17:51
  • My user (fabrizio) is already in dialout group: Apr 27, 2022 at 15:42
  • I have similar problem and even manually change permissions to 666 (with visual confirmation, I still get permission problem (user in dialout group, dialout group exits, device loaded in kernel.) @FabrizioCapobianco, you still have problem even if manually changing permission?
    – pbuck
    Sep 16, 2022 at 4:51

1 Answer 1

3

Just a hint that might be the cause of the problem (worth a shot). Change your device permissions by:

sudo chmod a+rw /dev/ttyUSB0

WARNING: This solution is only for testing purposes! For production usages you should dig deeper to this command and only active the options that is actually needed! (i.e. not giving every single user the ability to read, write and execute from your /dev/ttyUSB0)

1
  • This finally solved my Chirp problem on Debian 12 :) Mar 31 at 21:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .