9

I am currently experiencing some random screen flickering after a fresh install. I have a Lenovo laptop with Mesa Intel® UHD Graphics 620 (KBL GT2). It was working fine on 21.10.

5
  • 2
    smae issue here. This has been reported here too: bugs.launchpad.net/ubuntu/+bug/1970426
    – dimisjim
    Apr 29 at 6:54
  • This workaround worked for me: In file /etc/default/grub I added to parameter GRUB_CMDLINE_LINUX_DEFAULT the value "i915.enable_dc=0 intel_idle.max_cstate=2". Then updated grub and now I'm flicker free for a few days. May 10 at 18:17
  • @EstebanKnöbl My line in that file now has GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_dc=0 intel_idle.max_cstate=2" and I ran sudo update-grub but I still see the flickers. Any ideas?
    – MW Millar
    May 11 at 19:31
  • 1
    I don't have "quiet splash" there, but I don't think that's going to make any difference. And I'm guessing you reboot your system. Maybe you can check the bug report above to see if there's anyone else in your situation. May 12 at 10:22
  • Thank you, this workaround fixed this issue for me in elementary OS 6.1.
    – Andy White
    Aug 17 at 14:40

3 Answers 3

4

A bug has been reported at Launchpad. If you're experiencing this issue, you can report it too.

Until it's fixed, this workaround worked for me:

sudo nano /etc/default/grub

In the grub file, I added to parameter GRUB_CMDLINE_LINUX_DEFAULT the value "i915.enable_dc=0 intel_idle.max_cstate=2". Then saved the file and run:

sudo update-grub

... to update grub. I did a reboot. I'm now flicker-free for ten days.

1

Had the same issue right after installing Ubuntu 22.04 on ASUS Zenbook also running the Mesa Intel® UHD Graphics 620 (KBL GT2) integrated graphics.

After searching for a couple of hours, I came across a thread suggesting adding the intel_idle.max_cstate=4 kernel boot parameter in /etc/default/grub as a workaround.

So far it seems to have solved the flickering issue.

3
  • Thank you, I'll give it a try. Apr 26 at 21:11
  • Sadly, this didn't fix it. Apr 28 at 17:55
  • 2
    After giving this a go for a couple of days, I can now also confirm my self that this workaround only makes the flickering less apparent and a but more scarce but doesn't completely eradicate the issue. Furthermore, everything fills a bit laggy. Apps sometimes freeze for a second, even when I'm only doing lite work on my Laptop. At this point, it kind of feels broken all around, I, actually considering a fresh installation. Apr 28 at 19:04
0

Had the same issue with my dell inspiron-15-3567 got the fix by using acpi=off in /etc/default/grub but a new issue cropped up when shutting down system reaches shutdown target systemd-shutdown process-udevd is waiting so have to press down the power button . so have to choose between either screen flicker randomly or a shutdown issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.