When I start Rhythmbox by clicking the play button in unity control panel (the load gif), or start it manually, the rhythmbox unity plugin does not work. The control panel keeps in the loading state forever.

Idk what to do, the load state remains until I reboot the PC.

enter image description here


I had the problem after messing with the plug-ins.

I figured you really need to have the plug-in named "MPRIS D-bus interface" checked.

You will find the plug-in under edit > preferences > Plugins.

It should be like the 12th plug-in

enter image description here

| improve this answer | |
  • I confirmed this behaviour and added a screen-shot – RobotHumans May 24 '12 at 0:31
  • Thanks! The plugin was disabled, not sure how, but was. Now the menu is working fine. – MateusMolina May 24 '12 at 15:53

I have experienced Rythmbox not coming to the foreground when clicking some of the indicators in the panel if I have specifically:

  • Paused a song
  • Hidden the application with the X part of the menu
  • Tried to restart it from the panel

When this evidences, my workaround is to Alt+Tab to the application in order to get it on-screen.

As to the screen-shotting component, you use delay to get a screen-shot with a context menu...set the delay in Grab after delay of and cropping. Like this:

context screenshot

Either way, I believe the question is a bug report. Hence it becomes off-topic, but I thought I should clarify some steps I use to:

  • Work around the issue
  • Take screenshots
| improve this answer | |
  • thanks for the answer, the screenshot tip worked fine, however, about the ubuntu rhythmbox plugin, isn't what i was looking. – MateusMolina May 23 '12 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.