1

I'm using pavilion with ryzen5 5625u. I already tried this answer and disabled secure boot according another answer. I also ran sudo systemctl restart network-manager but it says it failed to restart . I also went to software and update for additional drivers, but it has no additional drivers to install.
it says no wifi adapter
output of cat /etc/modprobe.d/iwlwifi.conf
output of cat command

this is the output of ip a # check if you can see wireless card

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
3: usb0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000
    link/ether 42:be:a8:da:f2:40 brd ff:ff:ff:ff:ff:ff
    inet 192.168.42.182/24 brd 192.168.42.255 scope global dynamic noprefixroute usb0
       valid_lft 3593sec preferred_lft 3593sec
    inet6 fe80::2ace:eaf0:c3ba:8cf9/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

and output of lspci -knn | grep Network -A3 # This shows card name and driver, if in use.

libkmod: ERROR ../libkmod/libkmod-config.c:712 kmod_config_parse: /etc/modprobe.d/iwlwifi.conf line 8: ignoring bad line starting with '“options'
01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:b852]
    DeviceName: Realtek Wireless LAN + BT
    Subsystem: Hewlett-Packard Company Device [103c:88e3]
02:00.0 Non-Volatile memory controller [0108]: Samsung Electronics Co Ltd NVMe SSD Controller 980 [144d:a809]

Edit 1 output of my ifconfig is

$ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 488  bytes 60829 (60.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 488  bytes 60829 (60.8 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlx200db01052d8: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.12  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::45dc:7ce4:395e:7bf1  prefixlen 64  scopeid 0x20<link>
        ether 20:0d:b0:10:52:d8  txqueuelen 1000  (Ethernet)
        RX packets 12242  bytes 14993668 (14.9 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 9344  bytes 1371773 (1.3 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

and output of ifup and ifdown is

ifup: no interface(s) specified
ifup: Use --help for help
4
  • cat /etc/modprobe.d/iwlwifi.conf please add this to your question through edit there is a parse error ; kmod gives a warning.
    – nobody
    Apr 26 at 11:54
  • imgur.com/a/2WDYMlX this is the output of the command
    – ayu_j
    Apr 26 at 12:21
  • it says no wifi adapter when i went to settings
    – ayu_j
    Apr 26 at 12:26
  • 1
    remove the line beginning with "options iwlwifi and so on" in /etc/modprobe.d/iwlwifi.confand make a reboot. And please no images cp & paste the next time output from commands and edit your question for showing. this only remove the error from kmod.
    – nobody
    Apr 26 at 12:48

1 Answer 1

0

I'm not sure if this is any help, however I am using 22.04.1 Server. I am using a built in wi-fi card and I am connected. However in the GUI it does not show me using wi-fi according to the icon and the drop down. This is what my interfaces look like:

$ ifconfig
docker0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 172.17.0.1  netmask 255.255.0.0  broadcast 172.17.255.255
        ether 02:42:b1:0a:f1:5e  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 38:60:77:83:9c:d0  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 199  bytes 18849 (18.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 199  bytes 18849 (18.8 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.27  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::76de:2bff:fe3c:bab3  prefixlen 64  scopeid 0x20<link>
        ether 74:de:2b:3c:ba:b3  txqueuelen 1000  (Ethernet)
        RX packets 1532  bytes 814657 (814.6 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 957  bytes 167662 (167.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

interface wlp2s0 is my wifi card. Maybe use $ ifdown and $ ifup to see if that works for your situation. (sudo apt install net-tools if you don't have them already)

Hope this helps.

1
  • output of my ifconfig is posted on question, pls check it out
    – ayu_j
    Nov 24 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.