pretty new to everything Ubuntu, but trying to (ultimately) create a usb to live boot from with persistent storage. I've installed Ubuntu onto a system to run, as using Rufus with Windows continuously gave me a different error while trying to utilize the persistent storage option. I'm currently running 22.04 LTS and when I try to go through the commands to set it up, I first use: sudo add-apt-repository universe which returns

Adding component(s) 'universe' to all repositories. Press [ENTER] to continue or Ctrl-c to cancel. Hit:1 http://us.archive.ubuntu.com/ubuntu jammy InRelease Hit:2 http://us.archive.ubuntu.com/ubuntu jammy-updates InRelease Hit:3 http://us.archive.ubuntu.com/ubuntu jammy-backports InRelease Hit:4 http://security.ubuntu.com/ubuntu jammy-security InRelease Reading package lists... Done

followed by sudo add-apt-repository ppa:mkusb/ppa and receive (after a long pause)

Traceback (most recent call last): File "/usr/bin/add-apt-repository", line 364, in sys.exit(0 if addaptrepo.main() else 1) File "/usr/bin/add-apt-repository", line 347, in main shortcut = handler(source, **shortcut_params) File "/usr/lib/python3/dist-packages/softwareproperties/shortcuts.py", line 40, in shortcut_handler return handler(shortcut, **kwargs) File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 82, in init if self.lpppa.publish_debug_symbols: File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 120, in lpppa self._lpppa = self.lpteam.getPPAByName(name=self.ppaname) File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 107, in lpteam self._lpteam = self.lp.people(self.teamname) File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 98, in lp self._lp = login_func("%s.%s" % (self.module, self.class.name), File "/usr/lib/python3/dist-packages/launchpadlib/launchpad.py", line 494, in login_anonymously return cls( File "/usr/lib/python3/dist-packages/launchpadlib/launchpad.py", line 230, in init super(Launchpad, self).init( File "/usr/lib/python3/dist-packages/lazr/restfulclient/resource.py", line 472, in init self._wadl = self._browser.get_wadl_application(self._root_uri) File "/usr/lib/python3/dist-packages/lazr/restfulclient/_browser.py", line 447, in get_wadl_application response, content = self._request(url, media_type=wadl_type) File "/usr/lib/python3/dist-packages/lazr/restfulclient/_browser.py", line 389, in _request response, content = self._request_and_retry( File "/usr/lib/python3/dist-packages/lazr/restfulclient/_browser.py", line 359, in _request_and_retry response, content = self._connection.request( File "/usr/lib/python3/dist-packages/httplib2/init.py", line 1725, in request (response, content) = self._request( File "/usr/lib/python3/dist-packages/launchpadlib/launchpad.py", line 144, in _request response, content = super(LaunchpadOAuthAwareHttp, self)._request( File "/usr/lib/python3/dist-packages/lazr/restfulclient/_browser.py", line 184, in _request return super(RestfulHttp, self)._request( File "/usr/lib/python3/dist-packages/httplib2/init.py", line 1441, in _request (response, content) = self._conn_request(conn, request_uri, method, body, headers) File "/usr/lib/python3/dist-packages/httplib2/init.py", line 1363, in _conn_request conn.connect() File "/usr/lib/python3/dist-packages/httplib2/init.py", line 1153, in connect sock.connect((self.host, self.port)) TimeoutError: [Errno 110] Connection timed out

I've also attempted the unstable version, which gives me an error just like this. If I attempt to install usb-pack-efi or any others, including the purge command, I get an error Unable to locate package X (usb-pack-efi, mkusb-plug, etc etc. )

I'm not sure what I'm doing wrong and from searching around I'm not finding this same type of error anywhere else. Any help you can give would be amazing. Thank you.

  • Please read askubuntu.com/help/how-to-ask and askubuntu.com/help/formatting Especially the formatting one.
    – waltinator
    Apr 26, 2022 at 4:53
  • @Ells, I will try to help you, and I need to know some more details about your current Ubuntu system. In the 'answer' below I assume that you installed Ubuntu desktop 22.04 LTS and used it to install mkusb. Is that correct? Otherwise, what system were you using (A live system (in a USB pendrive)?, another version of Ubuntu ...)?
    – sudodus
    Apr 27, 2022 at 9:20

2 Answers 2


I was encountering the same error

TimeoutError: [Errno 110] Connection timed out

when trying to add PPAs on Ubuntu 22.04 eg.

sudo add-apt-repository ppa:rvm/smplayer

Disabling IPv6 resolved it.

These links cover how to disable IPv6 (and re-enable if that doesn't resolve your issue) https://linuxconfig.org/how-to-disable-ipv6-address-on-ubuntu-22-04-lts-jammy-jellyfish https://www.reddit.com/r/linuxquestions/comments/ai5ikk/comment/eelarvz

This is where I found the suggestion to disable IPv6 https://ubuntuforums.org/showthread.php?t=2474534&page=2

  • +1; Thanks for sharing this very special solution [and the links] :-)
    – sudodus
    Aug 30, 2022 at 18:30

I am using the answer format in order to render details of my questions easier to read.

You wrote

I've installed Ubuntu

I assume that you installed Ubuntu desktop 22.04 LTS and used it to [try to] install mkusb. In my installed system of that version I get the following dialogue, when trying your failing command (and some extra commands to explain what system I have),

$ sudo add-apt-repository ppa:mkusb/unstable
Förråd: 'deb https://ppa.launchpadcontent.net/mkusb/unstable/ubuntu/ jammy main'
MKUSB unstable
Mer info: https://launchpad.net/~mkusb/+archive/ubuntu/unstable
Lägger till förråd.
Tryck [ENTER] för att fortsätta eller Ctrl-C för att avbryta.
Adding deb entry to /etc/apt/sources.list.d/mkusb-ubuntu-unstable-jammy.list
Adding disabled deb-src entry to /etc/apt/sources.list.d/mkusb-ubuntu-unstable-jammy.list
Adding key to /etc/apt/trusted.gpg.d/mkusb-ubuntu-unstable.gpg with fingerprint 29D76ADA2D15A87BF4C68B823729827454B8C8AC
Bra:1 http://se.archive.ubuntu.com/ubuntu jammy InRelease
Bra:2 http://se.archive.ubuntu.com/ubuntu jammy-updates InRelease
Bra:3 http://se.archive.ubuntu.com/ubuntu jammy-backports InRelease
Bra:4 http://security.ubuntu.com/ubuntu jammy-security InRelease  
Läs:5 https://ppa.launchpadcontent.net/mkusb/unstable/ubuntu jammy InRelease [18,1 kB]
Läs:6 https://ppa.launchpadcontent.net/mkusb/unstable/ubuntu jammy/main amd64 Packages [1 580 B]
Läs:7 https://ppa.launchpadcontent.net/mkusb/unstable/ubuntu jammy/main i386 Packages [1 580 B]
Läs:8 https://ppa.launchpadcontent.net/mkusb/unstable/ubuntu jammy/main Translation-en [1 228 B]
Hämtade 22,4 kB på 1s (21,8 kB/s)                          
Läser paketlistor… Färdig

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 22.04 LTS
Release:    22.04
Codename:   jammy

$ df -h
Filsystem      Storlek Använt Ledigt Anv% Monterat på
tmpfs             1,6G   2,1M   1,6G   1% /run
/dev/sda1         150G   7,1G   135G   6% /
tmpfs             7,8G      0   7,8G   0% /dev/shm
tmpfs             5,0M   4,0K   5,0M   1% /run/lock
/dev/sda5         241M    18M   224M   8% /boot/efi
tmpfs             1,6G   2,4M   1,6G   1% /run/user/1000

Sorry that some text is in Swedish. I hope you can see that add-apt-repository works correctly for me.

Maybe there was a temporary error (because of problems with the internet or with the PPA server), but if you still get the same error when trying today, maybe there is some problem with your python libraries or with some other tools, that should help manage that command.

Have you checked that your Ubuntu system is up to date. What is the output of the following commands?

sudo apt update
sudo apt full-upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.