I update to Ubuntu 22.04 and Tor Browser is not working anymore. I removed Tor Browser and when I tried to re-install it by running "torbrowser-launcher", I get the following error message:

Tor Browser Launcher
Von Micah Lee, lizensiert unter MIT
Version 0.3.3
Erzeuge GnuPG Verzeichnis /root/.local/share/torbrowser/gnupg_homedir
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Lade Tor Browser das erste mal herunter.
Herunterladen https://aus1.torproject.org/torbrowser/update_3/release/Linux_x86_64-gcc3/x/en-US
Traceback (most recent call last):
  File "/usr/bin/torbrowser-launcher", line 30, in <module>
  File "/usr/lib/python3/dist-packages/torbrowser_launcher/__init__.py", line 98, in main
TypeError: arguments did not match any overloaded call:
  move(self, QPoint): argument 1 has unexpected type 'float'
  move(self, int, int): argument 1 has unexpected type 'float'

Thanks for your help!

  • Did you try to update Tor to latest 0.3.5 version? try to run ./build_deb.sh again. Apr 27, 2022 at 12:22

2 Answers 2


You can fix this by going into the __init__.py file and changing the lines (98) in /usr/lib/python3/dist-packages/torbrowser_launcher/:

            (desktop.width() - window_size.width()) / 2,
            (desktop.height() - window_size.height()) / 2


            int((desktop.width() - window_size.width()) / 2),
            int((desktop.height() - window_size.height()) / 2)

Another solution is posted on the official GitHub: https://github.com/micahflee/torbrowser-launcher/issues/636 (which in general does the same)

Both solutions are valid. I assume it will be fixed in the next update.

Explanation gui.move expects two integers, but can get two floats from the division. Therefore explicit casting to int is needed.

  • 2
    Another solution is posted on the official GitHub: github.com/micahflee/torbrowser-launcher/issues/636 (which in general does the same) This worked for me. Thanks Natan
    – jon57br
    Apr 30, 2022 at 8:42
  • 1
    Has a bug been filed? Until a bug is filed the developers can't know a fix is required to be made.
    – guiverc
    May 10, 2022 at 2:28
  • 2
    @guiverc yes, there is an Ubuntu bug - waiting on Upstream to have a patch for inclusion
    – Thomas Ward
    Jun 22, 2022 at 21:13
  • This is still an issue, seems like Ubuntu gets a stale torbrowser-launcher. I guess a solution is to get torbrowser from the producers directly, torproject.org/download. You untar it (tar xvf ./$packagename), cd to the directory, then just run ./start-tor-browser.desktop.
    – pbhj
    Sep 2, 2022 at 17:16

I have Ubuntu 22.04 and Tor Browser not launching (Error 404...) Well. But if I go, in the terminal, to


and type

  ./start-tor-browser.desktop --verbose

then Tor-Browser works, I do not why. Every time I start my system, I must do the same in this way

Not the answer you're looking for? Browse other questions tagged or ask your own question.