My Google Chrome app freezes when I select a file from an HTML input tag of type "file".

This is a very simple code to reproduce the error:


After I select any file, and even if I click on cancel, the Chrome window becomes unresponsive. I cannot click on anything, change the tab or close the windows.

I tried to disable "Use hardware acceleration when available", but it doesn't solve the problem.


  • Chrome Version 100.0.4896.127 (Official Build) (64-bit)
  • Ubuntu 22.04 LTS
  • HP HP ProBook 450 G8 Notebook PC*
  • Mesa Intel® Xe Graphics (TGL GT2)

5 Answers 5


Check the bug report here: https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1970148

As proposed by Olivier Tilloy in the bug report, the command

sudo apt install xdg-desktop-portal-gnome

solved my problem.

I am using Ubuntu 22.04 on Xorg with Nvidia card.

  • 4
    Thanks! it works
    – FabioDev
    Apr 27, 2022 at 12:52
  • 3
    I've tried this and didn't work here. Ubuntu 22.04 on Xorg as well. The error only occurs when I'm using Brave, Firefox and Chrome are fine. May 2, 2022 at 23:36
  • 4
    I already had xdg-desktop-portal-gnome installed and still faced this problem. Disabling hardware acceleration on Chrome fixed it for me.
    – kgx
    Jun 13, 2022 at 11:10
  • 1
    This didn't work for me and a also had hardware acceleration already disabled.
    – Rafael-WO
    Jun 21, 2022 at 10:58
  • 1
    fixed after reboot Jun 23, 2022 at 11:10

As I reported here in launchpad, and many user confirmed, the solution proposed do not always work. Probably this error can be caused by different setups and configurations.

In particular installing xdg-desktop-portal-gnome or disabling hardware acceleration didn't worked for me.

For those cases, I found a solution here:

Basically I used dconf-editor to turn to false org/gnome/desktop/sound/input-feedkback-sounds and this solved the problem.

Hope it helps.

  • +1, this worked instantly, whereas the xdg-desktop-portal-gnome was already installed and turning hw acceleration of is a no-go. Thanks!
    – Bachi
    Feb 6 at 17:45

Neither of the two suggestions (xdg-desktop-portal-gnome nor disable hardware acceleration) quite works for me. What I find is that I simply have to toggle disable hardware acceleration on and off at some point in my session. If I don't do that, the reported issue appears. The window completely freezes after a file upload dialog.

Version 104.0.5112.79 (Official Build) (64-bit) Ubuntu Description: Ubuntu 22.04.1 LTS

I do not experience this issue if I use google-chrome-beta on the same platform.

I hope that proves helpful to someone.

  • I find if I wait it out, like 5 minutes, it unfreezes, so I am trying to see who is sucking down the CPU all that time, if top is updating. I just got multiple freezes using gnucash showing a report, plus lots of dialog popups not responding kill or wait. Chrome with acceleration disabled (weird that there is such a control!) was running but all 4 windows minimized, also minimized libreoffice first screen, boinc manager, pulseaudio, disks, nautilus, gnome-terminal. Aug 18, 2022 at 17:22

Disabling hardware acceleration and restarting Google Chrome (v104) solved it for me. I wish there would be a better solution.

  • Where you do disable hardware acceleration?
    – warmwhisky
    Oct 7, 2022 at 9:05
  • Click on the three dots on the right of your browser window, select "Settings" > "System" and you should see a Checkbox that you can disable: "Use hardware acceleration if possible". A Chrome-restart is required.
    – anty
    Oct 7, 2022 at 10:14

dconf-editor solved this problem for me after turning "org/gnome/desktop/sound/input-feedkback-sounds" to "false".

You can install the dconf-editor by using the following command:

sudo apt-get install dconf-editorand then type dconf-editor in the terminal a pop-up window will open for dconf-editor and the nyou can navigate to the appropriate path and the n turn off the required setting then the problem is solved.

  • Thank for the clear explaination. it was the good solution for me Mar 20 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.