11

I've already performed the tests and changed the cable. I've come to the conclusion that it's not a problem with the cables or the monitors because I tested it with other distros even in Windows and the image is normal. I believe it's a problem with Wayland with the Nvidia video card, as my GPU is a GTX Nvidia GeForce 1650 Super.

enter image description here

enter image description here

3
  • with Xorg it works properly?
    – Esther
    Apr 25 at 15:37
  • 3
    I managed to solve the problem, I had to set the monitor calibration in Settings/Color and set sRGB as default for both monitors. Apr 25 at 21:05
  • Thanks, that was it @AleksanderPalamar . To people who can't see correctly, there's an arrow/chevron to the right in the monitor, click that and then delete the color profile. In the new menu scroll until you see sRGB and click on that!
    – eri0o
    Jun 17 at 22:36

2 Answers 2

5

It appears this is a reality. I was fine the other day before upgrading to 22.04 and now, my secondary display (my TV) has a yellow tint like it's stuck on Night Light mode. I've tried everything I can think of and I cannot fix the issue. I have also come to the same conclusion as you

UPDATE: It seems that the profile might be getting corrupted somehow? I removed the profile that was automatically assigned and set the RGB profile to D65 and everything seems fine again. I also tried a few others in the list and they seemed to be OK. Give it a whirl and it will likely solve your problem.

4
  • 1
    Yes, this is definitely an issue. I have an Asus TUF A17 which uses a TU116M [GeForce GTX 1660 Ti Mobile] on the USB-C output and AMD Renoir on the HDMI output. I have both of these outputs connected to identical Dell SR2320L monitors (via a USB-C to HDMI adapter on one). I use the nouveau drivers, and this worked under 21.10. After the upgrade to 22.04, the monitor connected to the Nvidia card displayed any lighter color as a shade of bright yellow. Deleting the monitor's color profile and replacing it with "Best RGB" fixed it.
    – terafl0ps
    Apr 29 at 15:25
  • 1
    "Best RGB" didn't support Night Light in my case and seemed like it had reduces colors. "Standard Space - sRGB" did for me. May 5 at 7:57
  • How do you delete the color profile?
    – eri0o
    Jun 17 at 22:34
  • 2
    Go to settings > color > select your monitor > add profile > Colorspace: sRGB. Jun 21 at 18:04
1

I fixed it.

New answer,

Reviewer said enabling wayland fixed it.

Set WaylandEnable=false to true

sudo nano /etc/gdm3/custom.conf

# set it to true

WaylandEnable=true

Then restart gdm3

sudo systemctl restart gdm3

Original answer

I was using nouveau, part of mesa, the default open source nvidia driver.

Somehow the windowing system switched from wayland to x11 and then I got yellow screen(1st screen) and red screed(2nd screen).

I reinstalled mesa related pkg.

sudo apt autoremove mesa*
sudo apt install mesa*

Then I

sudo nano /etc/gdm3/custom.conf

Set WaylandEnable=false to true

WaylandEnable=true

Then restart gdm3

sudo systemctl restart gdm3

I don't know when it switched to x11, but x11 doesn't seem to be working well with nouveau on ubuntu 22.

2
  • 1
    Just enabling Wayland fixed it for me
    – Snorky35
    May 23 at 12:37
  • 1
    For me the same.... Just enabling Wayland fixed it! Jul 8 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.