5

Here is how the icons look like in the Application Grid, Ubuntu 22.04 LTS. How to change icons size?

small icon size

Update: My display-settings:

  • Orientation Landscape,
  • Resolution 1366x768 (16:9),
  • Refresh rate 59,97 Hz,
  • Fractional Scaling OFF.

All using default config, nothing change. The device I'm using is an Acer E5-476G.

6
  • This looks smaller than expected, and is not expected behavior. That leads to the question: how did you customize your system? Use "edit" to add any relevant information about your desktop, extensions you may have installed, GTK themes and icon themes, etc., you may be using...
    – vanadium
    Apr 25 at 6:39
  • i dont know. this is a fresh install ubuntu im using
    – Shiroe
    Apr 26 at 2:25
  • It came to my attention that such effects can be caused by using fractional scaling: could you check Settings - Displays and add the information there to your question (use edit): Resolution, Scale and whether Fractional Scaling is on or off.
    – vanadium
    Apr 26 at 6:06
  • Ok i have update my post. oh btw, im using manjaro Gnome desktop before icon size is normal.
    – Shiroe
    Apr 26 at 7:23
  • 2
    It seems that GNOME 42 adapts the app grid icons size according to the screen resolution and the position of the dock. In my Ubuntu 22.04 (and 1366x768 screen resolution), if I put the dock on the bottom (instead of left), icons go back to a normal size. I think it's a GNOME 42 bug, because it didn't appear in previous versions. Apr 28 at 19:55

4 Answers 4

5

EDIT 2022/06/07: The issue has been fixed in GNOME 42.1. The solution implemented introduces minimal changes to solve the problem, moving a more robust and structured implementation to GNOME 43. See the history of this merge request for details.

ORIGINAL ANSWER: This is a bug that is tracked by the following ticket in Launchpad: Small icons in app grid of Activities Overview I suggest you and all other people that are affected by this bug (and that have a Launchpad account) to click the link "Does this bug affect you?", in order to arise the right importance to this issue.

Meanwhile, you can install a GNOME Shell extension to bypass the issue. It is called App-Grid-Tweaks. Even though it is available in GNOME Extension website, it is currently not compatible with GNOME 42, so you need to install it from git using the experimental branch.

The simple way is to use the following sequence of commands from the terminal:

wget -qO- "https://github.com/Selenium-H/App-Grid-Tweaks/archive/refs/heads/experimental.zip" -O "$(xdg-user-dir DOWNLOAD)"/App-Grid-Tweaks.zip
cd "$(xdg-user-dir DOWNLOAD)"
unzip App-Grid-Tweaks.zip
cd App-Grid-Tweaks-experimental
chmod +x INSTALL.sh
./INSTALL.sh
rm "$(xdg-user-dir DOWNLOAD)"/App-Grid-Tweaks.zip
rm -rf "$(xdg-user-dir DOWNLOAD)"/App-Grid-Tweaks-experimental

Ignore a possible error about locale files. Press ALT+F2, digit r in the box and press ENTER if you are using X11 display server, otherwise logout/login if you use Wayland.

Open the Extension app (if you don't have it, install it running sudo apt install gnome-shell-extension-prefs) and change the settings of the App-Grid-Tweaks, especially the icons size. In my machine, I have to press Press ALT+F2, then r everytime I change a setting. Sometimes, App-Grid-Tweaks settings are not available, but if you retry eventually they will open.

1

If you disable Ubuntu dock and install another dock, for example Dash to Dock for Cosmic, the bug disappears and everything is normal. So the bug seems to be attributable to Ubuntu dock and not to GNOME 42.

By applying another theme to the dock (fluent for example), no problem either.

0

setting/appearance/dock/size icons. if we decrease the size of the dock icons to 26 or less then the icons are big.

0
0

Bug has fixed, just update your system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.