I will preface this by saying I am not technically savey... I updated last night from 20.04 to 22.04 and now my wifi is not working. It doesn't show a wifi icon in the top right, or in the settings. Fn+F2 turns on airplane mode, but that's all. I have searched everywhere on-line, and have been unsuccessful trying everything I've found.

iwconfig outputs:


lo no wireless extensions.

enp1s0 no wireless extensions.

sudo lshw -C network outputs:

sudo lshw -C network

*-network UNCLAIMED

description: Network controller

product: QCA9565 / AR9565 Wireless Network Adapter

vendor: Qualcomm Atheros physical id: 0 bus info: pci@0000:02:00.0 version: 01 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list configuration: latency=0 resources: memory:b0500000-b057ffff memory:b0580000-b058ffff

nmcli r shows that everything is enabled.

I have tried updating the BIOS, and that didn't work.

There are no additional drivers in the Software and Updates settings. Any advice would be greatly appreciated.

  • 2
    What happens in terminal if you sudo modprobe -v ath9k
    – Jeremy31
    Apr 24, 2022 at 17:42
  • 1
    @Jeremy31 - It didn't produce an output. I ended up backing up my files and doing a clean install. The wifi works now with the clean install. Something must have gotten removed during the original upgrade from 20.04 to 22.04...
    – muuhdist
    Apr 25, 2022 at 21:19

1 Answer 1


I found that drivers didn't correctly update on: Ubuntu, Kubuntu, and Budgie. I also found that a clean install would correctly detect hardware, and for the moment have judged the in-place upgrade "not ready for prime time" and will hold off until there is better feedback. This is actually a long-standing issue with almost all flavors of Ubuntu, for whatever reason LTS-> interim releases have full hardware support, but interim (e.g., 21.10) to Long-Term support is pretty terrible. I remember reading a poster on askUbuntu advising to wait till July, now I understand why!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .