4

My Situation is the following:
I want to install Ubuntu jammy jellyfish 22.04 LTS instead of manjaro on my laptop. The laptop already had a working dual boot and so I thought replacing one Linux-system with another should not be a big problem.
While the Installation of jammy jellyfish seemed to succed, after restarting the laptop it ends up in a loop.
First it shows the normal screen it always shows before grub menu. It is a screen with some hardwaredata and the reminder to press F1 for a Bios menu.
Then it shows one mostly black screen and a message that disapers too fast to read.
After that there is another message saying "Reset system". Then it goes back to the first screen.

I can enter a menu in which there is the possiblity to choose bootmanager. If I choose "Windows 11" windows 11 starts normally. If I choose the other option begining with SAMSUNG (disk is SAMSUNG MZVLB256HBHQ-000L7(nvme)) I end up in the loop again.

Laptop: Lenovo Thinkpad T495
Earlier Installations: dual boot with Windows 11 and Manjaro KDE
Secure Boot: diabled
Istallation via: USB
Partition Table: gpt
Model SAMSUNG MZVLB256HBHQ-000L7(nvme)

There are five Partitions:
1: fat32 | EFI system partition | flags:boot, hidden, esp
2: no information | Microsoft reserved partition | flags: msftres
3: ntfs | Basic data partition | flags: msftdata
5: ext4 | - | - (I tried to install Ubuntu here)
4: ntfs | Basic data partition | flags: hidden, diag

I did enter sudo efibootmgr -c -g -w -L "ubuntu" -l "\EFI\ubuntu\shimx64.efi" -d /dev/nvme0n1 -p 1 while in "try Ubuntu"-mode.
The result was the following:
BootCurrent: 001B
Timeout: 0 seconds
BootOrder: 0001, 0016, 001B, 0017, 0018, 0019, 001A, 0000, 001C
Boot0000* Windows Boot Manager
Boot0010 Setup
Boot0011 Boot Menu
Boot0012 Diagnostic Splash Screen
Boot0013 Lenevo Diagnostics
Boot0014 Startup Interrupt Menu
Boot0015 Rescue and Recovery
Boot0016* USB CD
Boot0017* USB FDD
Boot0018* NVMe0
Boot0019* NVMe1
Boot001A* ATA HDD0
Boot001B* USB HDD
Boot001C* PCI LAN
Boot001D Regulatory Information
Boot001E* Boot Next Boot Option
Boot0001* ubuntu

In "Thinkpad setup -> Startup" (I think that is UEFI settings, I reached it by pressing f1 before booting) I get the following:
1 USB CD
2 USB HDD
3 USB FDD
4 NVMe0 SAMSUNG MZVL...
5 NVMe1
6 ATA HDD0
7 Windows Boot Manager
8 PCI LAN
there is no "ubuntu" entry

I tried to solve the problem by:

  • Installing with third party programs download enabled
  • Using the boot-repair tool: the tool ran for a long time, but there was no progress recognizable (even when I started it in debug mode)
    You can find the report under https://paste.ubuntu.com/p/pWmbMzN959 (Also because of some other attempts to get the dual boot to work, nvme0n1p5 now is called nvme0n1p6)
    Current report: https://paste.ubuntu.com/p/Wj6MJFSvbD
    I let boot-repair tool run again, but it still didn't do anything.

Any help with this would be greatly appreciated.

14
  • You should have an Ubuntu entry. And the drive entry is a fallback boot entry using /EFI/Boot/bootx64.efi similar to live installer's boot. But bootx64.efi may be the Windows boot file, the manjaro boot file, or grub/shimx64.efi from ubuntu's install. But it looks like Ubuntu's grub never correctly installed. Can you run report from Boot-Repair? If not you can try to chroot into system & reinstall grub or make other repairs.UEFI chroot, must include ESP - efi system partition askubuntu.com/questions/53578/…
    – oldfred
    Commented Apr 24, 2022 at 14:42
  • I will try to run a report. Commented Apr 24, 2022 at 15:01
  • I got an URL from boot-repair: paste.ubuntu.com/p/pWmbMzN959 is this helpful? Commented Apr 24, 2022 at 15:09
  • Not sure what hidden ESP is? Do you have a setting in UEFI that locks ESP? Some Lenovo have this: The Device Guard BIOS setting locks down the boot order to internal HDD/SSD only. You show /EFI/ubuntu from a grub install, but no UEFI boot entry in UEFI. Have you updated UEFI & SSD firmware? Many Lenovo need UEFI update. Does this give any error messages: sudo efibootmgr -c -g -w -L "ubuntu" -l "\EFI\ubuntu\shimx64.efi" -d /dev/nvme0n1 -p 1
    – oldfred
    Commented Apr 24, 2022 at 17:04
  • I don't know much about all the UEFI at all, so I dont know what's going on there. If there is a setting that locks ESP, wouldn't it already be disabled because there was a successful manjaro installation before? I don't know how to Update my firmware. Commented Apr 24, 2022 at 18:03

4 Answers 4

6

Ubuntu 22.04 comes with Grub 2.06 and on this version, the OS Prober is set to 'disable' by default which means you won't find the other OSes such as Windows on the Grub prompt as before. So here's a workaround.

Open grub config file,

sudo gedit /etc/default/grub

Then add this line

GRUB_DISABLE_OS_PROBER=false

enter image description here

Save the file and then run the following command:

sudo update-grub

Finally, reboot the system. You'll see the rest of the OSes on the Grub prompt.

Source: OMG! Ubuntu!

Edit

If this still didn't fix your issue, try to fix the Grub using boot-repair on a live session.

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

then

sudo apt-get install -y boot-repair && boot-repair
5
  • I just tried this. It didn't change the situation. My problem isn't that I don't see the windows os. I don't even get to the grub prompt. It just starts looping. Commented Apr 24, 2022 at 14:59
  • 1
    Have you tried to fix the Grub using boot-repair on a live session? sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update then sudo apt-get install -y boot-repair && boot-repair
    – Nipuna
    Commented Apr 25, 2022 at 9:05
  • Yes, I did that. It is how I got the reports. It ran a while, but didn't show any progress in the debug messages. Commented Apr 25, 2022 at 9:26
  • @Nipuna You gave the correct answer. But it cannot be repaired within the OS itself. You have to boot with the ISO on live CD, install the boot-repair program and fix the problem
    – acgbox
    Commented Apr 26, 2022 at 14:40
  • 1
    @acgbox Hey thanks. Yeah, that's what I meant by "on a live session". As per the OP's own answer, it appears he/she had a different issue with the BIOS settings, which is completely irrelevant to the Grub.
    – Nipuna
    Commented Apr 27, 2022 at 8:02
3

Turns out there is an option called "Boot Order Lock" in the Thinkpad Setup on the tap "Startup". Disabling it solved the problem.

The Startup menu. Option "Boot Order Look" is chosen and set to "disabled":

enter image description here

0

Try downloading the USB flash drive (or CD-R, if you have an optical drive) version of rEFInd. Write it to a USB flash drive (or CD-R) and try booting it. If it boots, it will probably show at least two Ubuntu options, one of which boots to GRUB and the other of which boots a Linux kernel directly. If either of them works, and if rEFInd's Windows option also works, you could try installing rEFInd to your hard disk, ideally via the Debian package or PPA. If this is successful, you'll boot via rEFInd, rather than GRUB, going forward.

The point of the above is to bypass GRUB, which seems to be misbehaving on your computer. Fixing GRUB is obviously another option, but I don't see any glaringly obvious configuration problems, so I have no suggestions for that approach.

1
  • I did follow the directions in rEFInd-README. Sadly I still did end up in the loop. I then tried finding rEFInd in the boot settings, and did not find it. My USB Stick appeared in the Boot Menu after pressing f12, but choosing it and pressing enter lead only to me reentering the boot menu. I am not sure what went wrong. Commented Apr 25, 2022 at 15:17
0

[Can't comment directly] The live session and boot repair did it for me on an old Acer S3-951 (BIOS). It had Win 10 22H2. When Ubuntu 24.04 installed it would only boot to Ubuntu. Running the tool brought back the Grub menu. Many thanks.

Hope this helps :)

btw the pastebin option that comes up sends a report to a url, just in case you don't know.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .