Hey I just installed my 22.04 Ubuntu and the installation was successful. Unforetunately I seem to be stuck in a "Reset System" boot loop which I can't seem to get out of.

When I boot the OS from the USB it works fine. Also my previous OS was Ubuntu 18.04 and it didn't have this issues. Any suggestions as to what might be the problem ?

  • 1
    Please read askubuntu.com/help/how-to-ask and askubuntu.com/help/formatting What is a "Reset System boot loop"? Are there any messages?
    – waltinator
    Apr 23, 2022 at 22:33
  • I have the same issue as well. For a short moment (maybe a second) there ist a Message "Boot System" in white text, then the system resets, goes through the bios and tries to boot again in an infinite loop. Apr 24, 2022 at 8:48
  • I solved this problem for my case by switching to EFI boot, turning on secure boot and reinstalling. After that I still had to manually change secure boot options (select which file to boot) in the BIOS, but I guess this is hardware dependant. @op maybe you can tell us about your hardware and check your boot settings (legacy or EFI, secure boot yes or no) May 3, 2022 at 10:57
  • I have the same issue on a new HP laptop in EFI. Tried F12 to get to boot menu with grub, no dice. White text "Reset System" appears top left. F12 tries to boot from network (not set up), then tries to get to grub boot menu, instead drops out to restart the cycle.
    – BaTycoon
    May 10, 2022 at 13:41

7 Answers 7


I had the same problem with my system. The problem is that it boots from /boot where it should boot from \EFI. You can test if this works by the method depicted by @Sudoanon. If this works you can define a customized boot option as follows.

  • Go into your bios
  • Go to boot options
  • Select add customized boot option
  • Define the path to be \EFI\ubuntu\grubx64.efi (or whatever works for you)
  • Set custom boot option as first priority in boot order.
  • Save and exit

This worked for me, I hope it works for you as well.

  • I confirm this solution works perfectly on HP ProBook 11 G1. This should be the accepted answer. Aug 25, 2022 at 16:21
  • Also worked on HP Probook 450 G2 Dec 10, 2022 at 12:59

I had this happen to my old HP laptop. I solved it temporarily by booting directly from the grub EFI file in BIOS but it still boot loops if I do not boot this way every single time.


I don't know why (probably because I use MBR partitions, NOT GPT!), but the grub-install in Ubuntu 22.04 installs the fbx64.efi into the /EFI/BOOT/ directory and during the boot the shim loader (in debug mode, activated via mokutil --set-verbosity true, I spent a while to debug this) shows Invoked from removable media path, ignoring boot optionsshim.c:912:load_image() attempting to load \EFI\Boot\fbx64.efi and immediately shows Reset System log. Removing a single \EFI\Boot\fbx64.efi file solves the Reset System issue. After the file removing the UEFI secure boot works just fine.

Hope this helps.

Details: MBR FS, Secure UEFI boot enabled, HP 2170p laptop

  • fbx64.efi is the fallback.efi boot loader that runs when the regular boot fails. It looks for a CSV file (like \EFI\ubuntu\bootx64.csv), creates an EFI boot entry for it, and reboots. fbx64.efi` isn't supposed to be installed on removable media - grub-install --removable skips it. The problem is that removable media is often booted by running the default boot loader, and if that's fbx64.efi then the EFI boot list will be changed every time the USB drive is booted.
    – bain
    Sep 5 at 20:31

On my HP Prodesk 800 this issue was resolved by disabling "fast boot" in the BIOS. Ubuntu immediately booted and continued to work as expected.


I ran into same problem on my HP PC. I was able to solved it with the following steps.

  1. Enter BIOS option
  2. In the Advanced tab, click Boot options
  3. Goto Boot Mode section to select UEFI Native (without CSM)
  4. Save settings and you are done

I got Fedora and Windows 11 dualbooted on my HP laptop (it doesn't need to be dualbooted), pretty sure that this is the same for other systems so do this, it fixed the problem for me:

Reboot your laptop, press the key on your keyboard that can make you select which partition you want to boot into. (mine is F9, for others it's varying)

Then, select the drive on where you installed Ubuntu, select EFI, then select BOOT instead of ubuntu (or your distro name)

Then, boot into BOOTX64.efi (NOT bootx64.efi in the ubuntu folder), then it'll show a fullscreen prompt that says "Boot Option Restoration", then there will be a countdown on the bottom left screen.

Then, just wait for it to complete, then once you restart your computer the GRUB bootloader should appear, your computer will be usable again, and the Reset System screen should be gone! :D


Had this on my Acer Aspire VN7-792G after reinstalling the system. Since I could not re-add the file (shimx64.efi in my case) for the attempt was rejected with “file is exist” I tried factory-resetting Secure Boot Config. I could add the file again afterwards and it worked.

I had to set a superuser password to alter secure boot settings, I could reset it to empty after doing my work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .