3

is there a way to install the current MEGAsync desktop client on ubuntu 22.04?

they offer megasync-xUbuntu_18.04_amd64.deb as the most recent version.

when i try to install it i get:

$ sudo dpkg -i megasync-xUbuntu_18.04_amd64.deb
Selecting previously unselected package megasync.
(Reading database ... 381862 files and directories currently installed.)
Preparing to unpack megasync-xUbuntu_18.04_amd64.deb ...
Unpacking megasync (4.6.6-3.1) ...
dpkg: dependency problems prevent configuration of megasync:
 megasync depends on libc-ares2 (>= 1.11.0~rc1); however:
  Package libc-ares2 is not installed.
 megasync depends on libcrypto++6; however:
  Package libcrypto++6 is not installed.
 megasync depends on libmediainfo0v5 (>= 0.7.56); however:
  Package libmediainfo0v5 is not installed.
 megasync depends on libssl1.1 (>= 1.1.1); however:
  Package libssl1.1 is not installed.
 megasync depends on libzen0v5 (>= 0.4.31-2~); however:
  Package libzen0v5 is not installed.

dpkg: error processing package megasync (--install):
 dependency problems - leaving unconfigured
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu3) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
 megasync

libcrypto++8 is available, but not libcrypto++6. libc-ares2 is available. libssl1.1 has no installation candidate; libssl3 is available.

first installing

$ sudo apt install libcrypto++8 libc-ares2 libmediainfo0v5 libssl3

reduces the error message to

dpkg: dependency problems prevent configuration of megasync:
 megasync depends on libcrypto++6; however:
  Package libcrypto++6 is not installed.
 megasync depends on libssl1.1 (>= 1.1.1); however:
  Package libssl1.1 is not installed.

but still - i was not able to install the package.

1
  • Use apt instead of dpkg: sudo apt install ./megasync-xUbuntu_18.04_amd64.deb
    – france1
    Commented Oct 2, 2022 at 16:54

3 Answers 3

6

They offer downloads for many different Ubuntu releases.

https://mega.nz/desktop

Make sure to use the scroll down menu and select "Ubuntu 22.04".

2
  • 1
    how could i miss this?! probably did not notice the scroll bar... thanks a lot! Commented Apr 24, 2022 at 6:24
  • It's partially their fault for not bundling distros releases and instead bundling them by roughly the release dates. So, Ubuntu 18.04, the oldest still supported release, appears first and it's followed by other distros releases of the same vintage. Ubuntu 22.04 was just released so it appears at the bottom of everything. Commented Apr 24, 2022 at 10:42
2

Did you try the flatpak version? That's the one I'm using, and it works fine.

https://flathub.org/apps/details/nz.mega.MEGAsync

-2

sudo dpkg -i megasync-xUbuntu_18.04_amd64.deb
If an error occurs, use this command to fix it
sudo apt install -f

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .