9

I have a NTFS partition. Before upgrading to Ubuntu 22.04, it was working perfectly and I could read/write/delete files with no problem.

However, after upgrading I can only read the disk and it says that it is a fuse filesystem, as you can see in the following screenshot.

Ntfs Properties

How do I fix it so it can be read/write/delete again?

7
  • 3
    Are you dual-booting with Windows? If so disable its Fast Startup feature and shutdown. If not then you shouldn't keep NTFS partitions around because when errors happen there's no way to correct them from Ubuntu or any other Linux. NTFS requires Windows tools. Commented Apr 23, 2022 at 17:30
  • This is not a Microsoft Windows problem. I have two laptops, both upgraded to the latest Ubuntu 22.04, I have the same problem on both laptops, I can only read from the disks. I do dualboot - In each laptop, there are two nvmee drives. One drive for Ubuntu and another drive for windows. I use GRUB as the bootloader, so windows has absolute no control over the Ubuntu boot. I do also boot into windows from GRUB. Commented Apr 23, 2022 at 17:41
  • 2
    It seems you understood very little, if any, of my previous comment. Your reply reads as and entirely different movie. Again, if you're dual-booting then please boot Windows, make sure Windows' Fast Startup feature is disabled and check the drives for errors. Then shutdown instead of rebooting to Ubuntu. Report back. Commented Apr 23, 2022 at 22:36
  • 2
    Disabling fast boot in windows did the trick. Thanks enormously! Your wisdom is deeply appreciated! 😁😇 My Apologies.. I was so focused on that it was a Ubuntu setting is was missing Commented Apr 24, 2022 at 13:51
  • @ChanganAuto you should turn this into an answer and get some points! Commented May 16, 2022 at 1:55

3 Answers 3

9

For my case, The command sudo dmesg | tail shows:

ntfs3: Unknown parameter 'windows_names'

It seems the new ntfs3 driver does not support the 'windows_names' flag anymore. Base on this suggestion I made /etc/udisks2/mount_options.conf file containing:

[defaults]
ntfs_defaults=uid=$UID,gid=$GID
ntfs_allow=uid=$UID,gid=$GID,nls,umask,dmask,fmask,nohidden,sys_immutable,discard,force,sparse,showmeta,prealloc,no_acs_rules,acl,noatime
3
  • ¡Excelent! This was the solution for me. I have Fast Boot enabled and working like a charm.
    – LogoS
    Commented Aug 22, 2022 at 11:10
  • It did the trick for me too !
    – user849355
    Commented Nov 15, 2022 at 12:58
  • Despite not changing anything in /etc/udisks2/mount_options.conf @hpascual answer worked and re-installing the ntfs driver solved the problem. Commented Jul 29, 2023 at 20:47
-1

Try this in terminal:

sudo apt remove ntfsprogs && sudo apt install ntfs-3g

Then reboot your system.

3
  • I have the same error, but ntfs-3g is already installed, and not ntfsprogs.
    – user849355
    Commented Nov 15, 2022 at 11:02
  • 1
    Despite having three downvotes, just a side-note that another new-user posted in an "answer" (that will likely be deleted since it is "not an answer") that this answer was the solution that worked for them. Unfortunately, they don't have the rep to comment or upvote just yet, but I encouraged them to return to it when they do to upvote it. Commented Dec 20, 2022 at 8:48
  • Despite not changing anything in /etc/udisks2/mount_options.conf just re-installing the ntfs driver solved the problem for me. Commented Jul 29, 2023 at 20:46
-5

Format your disk with NTFS format.

sudo mkfs -t ntfs /dev/sdc1

If you see error like " mkfs: failed to execute mkfs.ntfs: No such file or directory " then, install ntfs-3g package > sudo apt-get install ntfs-3g

After that, Format with NTFS, and, you'll access ntfs with no issue.

1
  • 8
    No issue? The data, if any, will be gone.
    – Ictus
    Commented Aug 21, 2022 at 7:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .