Just upgraded to 22.04. I have 2 identical monitors connected (to MB, using Intel graphics, one on HDMI, one on DisplayPort) and having this issue:

  • Both monitors wake and show MB logo (mirrored) when powering on
  • At the login screen, both monitors are detected separately - ie I see the login on one of them but can move my mouse cursor to the other
  • Once I log in, the second one goes off and I only have one
  • In the Displays setting, it is set to Single Display. I can then change it back to Join Displays to get the second one back
  • Same goes for display sleep - when I wake it, I need to re-enable the second display

I had this issue occasionally in 20.04 when I was using Xorg - but it's now very consistent with 22.04 wayland (I want to use Wayland since it solves screen tearing).

Any ideas for this? My second display is actually portrait and with an offset so it's really clunky to reset it every time.

  • similar issues here but on xorg, no solution Apr 26, 2022 at 13:01
  • @Matthew any luck on this?
    – Majesty
    Aug 4, 2022 at 12:10
  • 1
    @LuninRoman - this somehow magically fixed itself for me. Only to be replaced by some frequent (Wayland-specific) mouse/system lag after waking...
    – Matthew
    Aug 8, 2022 at 21:02

3 Answers 3


First set your display mode as desired using Settings > Devices > Displays
Next, open your terminal and cut and paste the line below. It worked for me for 20.04 and 22.04. Original post link J D

If you see an error message, it's probably the location of monitors.xml, you can find alternatives in the link.

sudo cp ~/.config/monitors.xml /var/lib/gdm3/.config

  • worked for me too, thanks man!
    – Majesty
    Aug 5, 2022 at 4:48

you just need to put the following to the /etc/X11/xorg.conf, logout and relogin, it will work.

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"

Section "Device"
    Identifier     "Device1"
    Driver         "i915"
    VendorName     "UHD Graphics 750"
    BusID          "PCI:0:0:2"

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

If you've been using NVIDIA graphics card, I would suggest to run the command:

sudo ubuntu-drivers autoinstall
sudo reboot

It worked for me!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .