After installing vpnc, network-manager-vpnc and network-manager-vpnc-gnome, the "Cisco Compatible VPN (vpnc)" option appears on the "Add VPN" menu in network manager as intended. The problem I'm having is that, despite having filled all necessary fields (so, gateway, user/group name/password), the "Add" button stays greyed out. It does seem to be a bug, since if I fill the gateway and the user name fields, the button will go green if I type only one character in the group name field (it doesn't save, however).

  • 1
    Same here. It was working fine with those packages on 20.04. Apr 23, 2022 at 16:16
  • I tried the solution of daltux, but that didn't work for me. I use Ubuntu 22.04, a fresh installation and I use network-manager-vpnc and the gnome GUI version 1.2.8-2 The solution of Manuel Uberti does work though. It changes my public IP nr and I get a tunnel to the server, but I cant access anything on the network I am connecting to. I may try another VPN clients, like softether-vpnclient that is in the repositories.
    – adonet
    Apr 27, 2022 at 12:49
  • Mayby this can help? answers.launchpad.net/ubuntu/+question/701185 Have some VPN problem on 22.04, when 20.04 works all fine.
    – fuss
    Apr 27, 2022 at 15:48
  • 1
    Same here. It was working fine with for me with these packages on 18.04 and 20.04. it doesn´t work via terminal with vpnc-connect or network
    – Muan
    May 5, 2022 at 19:13

2 Answers 2


The form validation seems buggy and there is a required field ("interface name") which was not required before. It is in the "Advanced" window.

There is a GUI workaround. Instead of editing the connection with the main Gnome Settings application, you have to do the following:

  1. Launch Advanced Network Configuration (or run nm-connection-editor from terminal)
  2. Click the "+" (Add a new connection), choose "Cisco Compatible VPN (vpnc)", click "Create..."
  3. Fill all the fields
  4. Click the "Advanced..." button
  5. Fill "Tunnel interface name" with tun0
  6. Click "Apply"
  7. The Save button will still be disabled. Click "Advanced..." again and "Apply", or try ticking "Use hybrid authentication" and then tick it again.
  8. Finally, you will be able to "Save"!

This is tested on Ubuntu 22.04, Lubuntu 22.04, Pop!_OS 22.04, all with network-manager-vpnc-gnome version 1.2.8-2.

Bug reports on this issue already open in each project:

  • 2
    Thank you for this, I can confirm it works. Apr 26, 2022 at 10:09
  • 6
    Ubuntu 22.04: for me after point 7 the Add button is still disabled
    – Mark
    May 3, 2022 at 9:25
  • 2
    sudo nm-connection-editor helped me out with an Anyconnect server. May 23, 2022 at 10:45
  • 9
    This worked for me ONLY when I ran nm-connection-editor from the terminal. It did NOT work when I went to the network configuration in the settings gui.
    – Phoenix
    Sep 27, 2022 at 17:17
  • 2
    Works on 22.04.1. Note that you you can't find the vpn configuration using the standard UI Oct 18, 2022 at 14:20

To temporarily work around this issue, I am using the command line approach for now by connecting to the VPN I need through the vpnc command.

I followed the instructions from Using vpnc as a Command Line VPN Client, so basically this is what I did (as root user):

  • I copied /etc/vpnc/default.conf to /etc/vpnc/myvpn.conf
  • I filled /etc/vpnc/myvpn.conf with the details of my VPN:
IPSec gateway mygateway
IPSec ID mygroupid
IPSec secret mygrouppassword
IKE Authmode psk
Xauth username myuser
Xauth password mypass
  • Then, as root, vpnc myvpn.conf (or as normal user: sudo vpcn myvpn.conf)
  • To disconnect vpnc-disconnect as root (or as normal user: sudo vpnc-disconnect)

It's not as handy as clicking through the UI, but at least it's working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .