11

I cannot run any appimage on Ubuntu 22.04. Of course I went to the propriety and put the flag on "run as executable" but once i double click on it nothing happen. I tried 3 appimages but nothing happen. Anyone knows how to fix it? Thanks

3
  • Check file permissions in the terminal to see if executable bit is set. Try running from the command line: errors may be displayed in the terminal that hint to the problem.
    – vanadium
    Apr 22, 2022 at 16:50
  • Thanks for your reply. I found that i needed to install libfuse2 to make them work Apr 22, 2022 at 17:06
  • OK, then you may not have a default install - probably an upgrade
    – vanadium
    Apr 22, 2022 at 18:35

2 Answers 2

21

Ubuntu 22.04 will no longer ship with the libfuse2 package by default. The AppImage distribution (and more generally, all existing AppImage's) are built expecting libfuse2 support. This means that AppImage's will not run on Ubuntu 22.04 by default.

The user would have to manually run:

sudo apt install libfuse2*

prior to executing any AppImage.

2
  • There must be something else because libfuse2 does not help.
    – treyiii
    Nov 10, 2022 at 18:14
  • As a SO fan boy, I run this command. Or more like installed the fuse2 and libfuse which meant that fuse3 was removed among other gnome packages on my Ubuntu 22.10. Only to find out it broke the Gnome desktop interface preventing any boot. So be INFORMED.
    – Lukas
    Jan 24 at 14:08
1

So I upgraded from ubuntu 20.04 (where .appimage was working fine) to 22.04 (where .appimage isn't running anymore) when I double click on icon it won't open when I run it using the terminal ./<.appimage name> it gives me this error "[359794:1206/185235.385867:FATAL:gpu_data_manager_impl_private.cc(1034)] The display compositor is frequently crashing. Goodbye. Trace/breakpoint trap (core dumped)" even after I downloaded libfuse2 and made sure it was executable. I'm not sure why this works or if there's maybe something wrong with this method but it worked for me. You can navigate to your directory where the app is installed open the terminal and type this ./<your .appimage name> --no-sandbox and that's it. Again I'm not really sure why this would work but it does at least for me.

2
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. To get notified when this question gets new answers, you can follow this question. Once you have enough reputation, you can also add a bounty to draw more attention to this question. - From Review
    – Vasilisa
    Dec 10, 2022 at 16:27
  • The '--no-sandbox' flag worked for me.
    – user107425
    Dec 28, 2022 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.