16

My wifi connection keeps disconnecting frequently (say once in a couple of minutes) sometimes it gets back and sometimes I need to activate and deactivate aeroplane mode. I tried to change my network provider to make sure it is this laptop problem and not the internet I use. The same happened with ADSL connection, android hotspot, and TD LTE modem. Really annoying. Some info: output of lspci -knn | grep Net -A2:

02:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    Subsystem: Lite-On Communications Inc AR9485 Wireless Network Adapter [11ad:6628]
    Kernel driver in use: ath9k
    Kernel modules: ath9k

and out put of grep wlan /var/log/kern.log:

Apr 17 21:26:24 mb-X202E kernel: [   18.970719] ath9k 0000:02:00.0 wlp2s0: renamed from wlan0
Apr 17 23:49:29 mb-X202E kernel: [   19.312256] ath9k 0000:02:00.0 wlp2s0: renamed from wlan0
Apr 18 00:30:25 mb-X202E kernel: [   18.915112] ath9k 0000:02:00.0 wlp2s0: renamed from wlan0
Apr 18 12:26:07 mb-X202E kernel: [   21.278385] ath9k 0000:02:00.0 wlp2s0: renamed from wlan0
Apr 18 22:21:55 mb-X202E kernel: [   19.425881] ath9k 0000:02:00.0 wlp2s0: renamed from wlan0
Apr 21 19:56:26 mb-X202E kernel: [   18.985724] ath9k 0000:02:00.0 wlp2s0: renamed from wlan0

Ubuntu 22.04

Gnome 42

Asus X202E

4
  • 2
    Did you try these solutions? askubuntu.com/questions/1353705/…
    – chili555
    Apr 22, 2022 at 14:43
  • @chili555 thank you very much. looks like disabling the power saving works, at least for the recent couple of minutes. I need to wait a little more and see. By the way, when I have set power mode to balanced in power settings, why there must be a power saving setting like that enabled? Apr 22, 2022 at 14:54
  • 1
    I haven't any ideas as to the balanced power settings. I recommend that you implement all of the other solutions in my post, as well.
    – chili555
    Apr 22, 2022 at 15:42
  • 1
    Please check my troubleshooting steps here: askubuntu.com/questions/1353705/…
    – chili555
    May 1, 2022 at 13:30

9 Answers 9

7

Try:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

And change wifi.powersave to 2

1
  • I had a similar issue with a HP EliteBook 850 G3 with Intel Corporation Wireless 8260. This trick works and avoids messing around with custom kernels. Apr 1 at 4:57
7

I tried most of the answers above, some of them worked but the problem started again after a couple of hours. Finally I installed a fresh Ubuntu and get rid of the disconnection syndrome but the same thing started to happen the day before yesterday.

At last my searches led to a bug with the 5.15 kernel and I found that there are many people facing the same problem with 5.15 and 5.16 kernels. I just updated to the latest kernel (5.17.7) and it has solved the problem for two days now.

I tried this solution to update to the latest kernel

1
  • I can confirm this has also resolved my wifi issues. Upgraded the kernel to 6.1.11-060111-generic from 5.15.* Feb 10 at 8:31
6

Had the same bug (same wifi chipset, but in an old Toshiba) after installing Ubuntu 22.04.

Appears to be a bug in the 5.15 kernel, and solved by installing the 5.17 kernel.

I did the following :

wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.17.5/amd64/linux-headers-5.17.5-051705_5.17.5-051705.202204271406_all.deb
wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.17.5/amd64/linux-headers-5.17.5-051705-generic_5.17.5-051705.202204271406_amd64.deb
wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.17.5/amd64/linux-image-unsigned-5.17.5-051705-generic_5.17.5-051705.202204271406_amd64.deb
wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.17.5/amd64/linux-modules-5.17.5-051705-generic_5.17.5-051705.202204271406_amd64.deb
sudo dpkg -i linux*.deb

Then I rebooted, and wifi works fine now.

4

i had an old machine with (linux ubuntu lts 22.04) internel wifi hardware named intel corporation centrino wireless-n 1000 condor peak. i had tried all methods, installing differnt kernels, but nothing worked me. after rigorous research i found this thread https://ubuntuforums.org/showthread.php?t=2274336. Steps to follow

  1. Go to wifi settings
  2. Go to ipv6 tab
  3. Disable

My wifi is much much faster, Full speed and No slow browsing reply and give a thumbs up, if this works for you

1
  • Thank you! This one worked for me with 24 hrs+ uptime and no notifications.
    – Yimin Rong
    Jul 3 at 15:20
3

Similar behavior, wifi keeps disconnecting and malfunction

my hardware : laptop Asus N751JK Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01) Subsystem: AzureWave AR9462 Wireless Network Adapter

I was runing Ubuntu 20.10, 21.04 up to Ubuntu 21.10 with Kernel 5.13.0 without any problem. I migrated to Ubuntu 22.04 which installs Kernel 5.15 then the problems started. I upgraded and tested unsuccessfully the following Kernels : 5.15.28, 5.15.36, 5.16.14, 5.16.20, 5.17.4, 5.17.5

I disabled the power save as explained without improvement in any of the Kernels tested. Also the "intel_iommu=off" mentioned at https://groups.google.com/g/linux.debian.kernel/c/RFpPIp0cncA/m/v9ELDxLICgAJ Bug#994590 didn't help.

I downgraded and currently running without any problem using the Kernel 5.13.19-051319-generic.

There is no problem in my airpoint (router) nor my internet access, I have other different computers and devices working correctly on wifi. In addition the N751JK works correctly when using the Ethernet adapter for the physical cable.

more on this https://bugzilla.kernel.org/show_bug.cgi?id=215703

https://bugzilla.kernel.org/show_bug.cgi?id=215698

https://bugs.archlinux.org/task/74187

https://bugzilla.kernel.org/show_bug.cgi?id=215698

2

So I tried all of the solutions listed here, however, what worked me was upgrading the Kernel to 5.17.14-051714-generic. It's been working for about 30 minutes. I will update this thread is the issue persists. Fingers crossed!

My specs: Clean install Ubuntu 22.04.1 with Intel Wireless PCI-e card.

Good Luck!

1

Using the solution mentioned in @chili555 comment, I tried disabling Power saving and it worked sofar (at least for the recent 20 minutes which is a record):

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*

P.S: By the way, when I have set power mode to balanced in power settings, why there must be a power saving setting like that enabled?

1

Probably not a solution, but helped me.

  • Being on Ubuntu 22.04/DELL Precision 5540/Wireless-AC 9260
  • after multiple upgrades and downgrades
  • trying kernels5.0.0-23, 5.13.19-051319, 5.15.0-47, 5.19.5-051905

i became desperate and started writing a re-connecting script, following How to connect and disconnect to a network manually in terminal?

But as soon as i tried the first command to connect from terminal:

$ nmcli device wifi connect MY_SSID password "MY_PW"

The connection became stable and not interrupting any more!

1

after installing the 5.17 kernel there may be a problem with updating the program core and the appearance of the message system:

error: bad shim signature.

error: you need to load kernel first.

press any key to continue...

it can be fixed by disabling secure boot from BIOS

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .