I just installed qemu and ran

qemu-system-i386 -hda ubuntu32 -cdrom ~/Downloads/ubuntu-12.04-desktop-i386.iso -m 1024 -boot d

and got some errors

Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory
Back to tcg accelerator.

Anyone know why this happens?


I am by no means an expert, however from what I know this could happen because either:

a) Your CPU does not support hardware virtualization

b) CPU does support virtualization, but you have not enabled it in BIOS.

  • I had the same issue and trying to load the KVM kernel module would give this error: FATAL: Error inserting kvm_intel /lib/modules kernel/arch/x86/kvm/kvm-intel.ko Operation not supported -- your solution worked for me as well. I just had to shutdown and unplug the laptop after changing the BIOS setting to enable virtualization support
    – Aras
    Aug 25 '12 at 1:28
  • I have the same issue on ubuntu 12.04 server. I even installed cpu-checker and ran kvm-ok which returned INFO: /dev/kvm exists and KVM acceleration can be used. Have run kvm in the past on this machine, stumped as to what I've done differently this time. May 20 '14 at 22:37

I too faced the same error and this worked fine for me ! Try to run this command and then run ur guest .

modprobe kvm-intel

Hope it should work fine !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.