1

Currently, I am trying to install Ubuntu alongside with Windows 10. Even though I followed multiple instructions and it seemed to install successfully.

After installing successfully (there was a notification telling me that), I clicked restart and it gave me back to the Windows 10 without asking me about booting options.

When I tried to reinstall, I can still see Ubuntu there but when I reboot again, it still gave me Windows 10.

I tried to erase and install Ubuntu again (by clicking the first install option). As well as click "Something else" but none of that work for me.

Every time I boot by USB, the GRUB still appeared when I successfully installed and restarted. No GRUB menu appeared.

I followed this link: https://www.itechguides.com/dual-boot-ubuntu-windows-10/ and this link https://itsfoss.com/guide-install-linux-mint-16-dual-boot-windows/ but nothing work. I disabled the Secure boot, I checked the Boot option in BIOS but nothing could be fixed because Ubuntu option was not there.

I also saw some places suggested to install GRUB in Ubuntu but how can I do that when I cannot even enter the Ubuntu after installing it.

9
  • You need to make sure that your motherboard BIOS boots Ubuntu first. This will load GRUB so you can choose the OS on each boot. If you boot to Windows, you won't get a choice. You also must install Ubuntu using the same UEFI/BIOS method as the current Windows installation. This is typically UEFI so you have to boot the installation USB as UEFI. If you're not sure, start over and use the official tutorial - It doesn't cover dual boot directly but there is a tooltip with a link to instructions for installing alongside Windows.
    – Nmath
    Apr 20, 2022 at 20:39
  • Seems strange that there is no option to boot Ubuntu in your BIOS ( or is it UEFI ?). 2 options: 1)What you can do is install 'Grub2Win' in Windows. If that detects your Ubuntu installation, set it as default bootloader. (You still have your Windows bootloader in the EFI partition.) 2) Boot from USB, choose 'try Ubuntu'. Then go to the terminal and type 'sudo apt install grub'. Shutdown ( works better than restart ), take out the USB. Restart and look in your BIOS/UEFI if you can boot from Ubuntu now. Apr 20, 2022 at 20:57
  • @Nmath hello, I think I did all of that already.
    – Nguyen Huy
    Apr 21, 2022 at 14:41
  • @HomerSimpson it said that package "grub" has no installation candidate. It suggests me to use grub2-common, grub-pc or something instead.
    – Nguyen Huy
    Apr 21, 2022 at 14:42
  • @HomerSimpson sadly, the solutions do not work.
    – Nguyen Huy
    Apr 21, 2022 at 14:49

2 Answers 2

1

Enable Dual-boot options from Windows Command Prompt

  1. Type cmd in the Windows search bar
  2. Right-click on Command Prompt
  3. Select "Run as administrator"
  4. In the Windows command prompt, enter bcdedit /set {bootmgr} displaybootmenu yes and press enter.

Configure default operating system in Windows Startup and Recovery

  1. Press Win+I to open settings (or just go to settings)
  2. Go to system -> about (click on the about tab in the system settings)
  3. Scroll down to the Related settings section and click on Advanced System Settings. On older Windows computers, go to Control Panel -> System and Security and click on Advanced System Settings from the left pane. 4.In the System Properties window that appears, find the Startup and Recovery section and click the Settings button.
  4. In the System Properties window that appears, Startup and Recovery, and click the Settings button
  5. In the Startup and Recovery window, smack the drop-down labeled as "Default Operating System" and choose your preferred OS.
  6. Next, check the "Time to Display List of Operating Systems" option and set it to whatever time you choose (30 seconds is recommended) Once this time elapses, it will automatically boot the OS you chose as default.
  7. Click OK to save changes.

Configure the Boot Manager with EasyBCD

  1. Go to the Neosmart EasyBCD page and click on See More.
  2. EasyBCD is available in Commercial and Non-commercial versions. Click on "Register" in order to download the free version and then enter your credentials (email, chosen username, etc) in order to download the tool.
  3. Run the installer and wait for the app to install.
  4. Launch EasyBCD and click on the "Edit Boot Menu" button. 5.Here you will see a dual boot entry listed as default. If you want to change the default OS, tick the box under the "Default" column for the entry you want to set as default.
  5. Under "Menu Options", check the "Use Metro Bootloader" option.
  6. Select "Count down" from and set it to 30 seconds or whatever time you choose.
  7. Click "Save Settings", and you will see a message that says "Bootloader settings saved successfully".

Disable the Windows Fast Startup Feature

  1. Press Win + R to open the Run dialog box. Search for "Control Panel" and click OK to open the "Control Panel" after you have searched.
  2. In the Control Panel, go to "System and Security -> Power Options".
  3. In the right pane, click on "Choose what the power buttons do".
  4. Click on "Change Settings that are currently unavailable". Now you will be able to access the greyed-out "Shutdown settings".
  5. Uncheck the "Turn on fast startup (recommended)" option.
  6. Click on "Save changes" to turn off fast startup in Windows.

Source: https://www.makeuseof.com/windows-10-dual-boot-option-not-showing/

1
  • IN WIndows 11, "Windows Startup and Recovery" is apparently not in Control Panel anymore; I tried to look for it in "Settings" and there I got "Advanced startup" with "Restart your device to change startup settings, including starting from a disk or USB drive", and then "Restart now" button - is that the same? I hate these fucking changes so fucking much, I wish they just documented the changes, the stupid fucks
    – sdaau
    Dec 17, 2023 at 10:14
1

Sorry for replying late. Thank you very much for your comments.

After multiple attempt to install, I finally did it. It turns out that the Ubuntu image that I tried to install (this is the one from one of my course) was incorrect. The moment I change to the Ubuntu 20.04 I downloaded from the official website. Everything was done.

Thank you very much, Huy Nguyen.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .