19

I'm trying to install Rocker Chat which I downloaded from the official GitHub repository. I do this command:

sudo apt install ./rocketchat_2.17.11_amd64.deb

After installation I get this message:

N: Download is performed unsandboxed as root as file '/home/deepdows/Downloads/rocketchat_2.17.11_amd64.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

When I try to run the rocketchat-desktop I get:

[bugsnag] Loaded!
[24506:0420/152301.161454:FATAL:gpu_data_manager_impl_private.cc(986)] The display compositor is frequently crashing. Goodbye.
Trace/breakpoint trap

But if I do rocketchat-desktop --disable-gpu-sandbox It will run just fine.

I already tried

sudo chown _apt /var/lib/update-notifier/package-data-downloads/partial/
sudo chmod -Rv 700 /var/cache/apt/archives/partial/
sudo chmod -Rv 755 /var/cache/apt/archives/partial/
sudo chown -Rv _apt:root /var/cache/apt/archives/partial/
sudo chmod 777 rocketchat_2.17.11_amd64.deb

Nothing worked

6
  • 3
    The apt download sandbox has nothing to do with this rocketchat GPU sandbox. They're completely unrelated.
    – muru
    Apr 20, 2022 at 12:53
  • why is there couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied) error then?
    – deepdows
    Apr 20, 2022 at 13:02
  • 2
    It's not an error, it's not even a warning. It's just an informational note (N:)
    – muru
    Apr 20, 2022 at 13:16
  • 1
    That's the part you should be focusing the post on. Add information relevant to that, like your GPU, Ubuntu version, kernel version, graphics driver version, whether you're running X11 or Wayland, etc.
    – muru
    Apr 20, 2022 at 13:51
  • 1
    The problem appeared after upgrading from 21.10 to 22.04 Ubuntu 22.04 LTS, 64-bit, GNOME 42, X11, kernel 5.15.0-25-generic, NVIDIA Corporation GA107M [GeForce RTX 3050 Mobile]
    – deepdows
    Apr 20, 2022 at 14:33

1 Answer 1

40

That means _apt user does not have access to the downloaded apt file.

This is often due to the fact that the Downloads folder is by-default inside the /home/user folder - in your case /home/deepdows - and that folder is by-default non-readable by others.

Just move rocketchat_2.17.11_amd64.deb to /tmp for example, and install from there: you will get rid of that warning.

5
  • 3
    I didn't have this problem before upgrading to 22.04 (I had 21.10) I also have already tried what you suggest, I don't have the warning, but still, the app is not running
    – deepdows
    Jul 3, 2022 at 9:03
  • 2
    Same here. Ubuntu lts 20.04 running from wsl2 didn't give me that warning, while 22.04 lts, clean ubuntu install, shows it.
    – ZenVentzi
    Aug 29, 2022 at 9:46
  • 1
    After copying to /tmp it worked for me. By the way, I am not using rocketchat, it worked for other deb file
    – taserghar
    Dec 18, 2022 at 3:10
  • I had the same Information [N]ote on Ubuntu 20.04 when installing opera-stable_87.0.4390.25_amd64.deb not from ~/Downloads folder but from another partition. Nevertheless after such installation Opera worked normally. Jan 21, 2023 at 19:15
  • 1
    Fresh install of Ubuntu 22.10. Downloaded debs for VSCode, DBeaver, and Docker Desktop to ~/Downloads. Installed with sudo apt install ./thefile.deb. I get the same error, but the package still gets installed and works.
    – odigity
    Mar 12, 2023 at 0:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .