12

I really want to use the latest Ubuntu 22.04 LTS, BUT when i tried to install the Viber, The viber won't work and it says "No Connection" even I have an internet connection:

Viber No Connection ScreenShot

Hope anyone can help. thank you!

I install this: https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb

5
  • Looking at the supported platforms notes, it looks like the installation file may be targeted to work with specific libraries. Are there any error messages in /var/log/syslog (or elsewhere in /var/log) that might point to the issue?
    – matigo
    Apr 20, 2022 at 10:06
  • Hi @matigo Thank you so much for your response here. I really appreciate it. I checked the supported platforms, and it seems that my system is supported "Linux Fedora and Ubuntu (64 bit)" I'm using 64bit. While checking the /var/log/syslog and doing tail -f /var/log/syslog while opening the Viber app, there is no logs on syslog mmmh.. what specific logs name do you mean on elsewhere in /var/log ?
    – Rey Mark
    Apr 20, 2022 at 10:17
  • 1
    You can copy the libraries from libssl1.1_1.1.1l-1ubuntu1.3_amd64.deb inside /opt/viber/lib and you're set. May 10, 2022 at 14:17
  • answer based on @GeorgeLitos comment askubuntu.com/a/1409882/652604
    – madzohan
    May 21, 2022 at 20:34
  • 1
    Viber is always broken for Linux, always late on the dependencies. Maybe submitting a ticket would help? Go here and answer "No" to "Did this answer your question?", then submit a ticket asking them to update Viber to libssl3 on Ubuntu 22.04: help.viber.com/en/article/supported-platforms
    – Majal
    Jul 28, 2022 at 6:29

6 Answers 6

12

Ubuntu moved to libssl3 with 22.04, as libssl1.1 has been deprecated. You have to get libssl1.1 from 21.10 and make Viber work with it. Here are instructions:

wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.1l-1ubuntu1.3_amd64.deb

sudo dpkg -i libssl1.1_1.1.1l-1ubuntu1.3_amd64.deb

sudo nano /usr/share/applications/viber.desktop

Then change the Exec line to:

Exec=LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libssl.so /opt/viber/Viber %u
7
  • Hi Filip, Thank you so much for your help. This solved my problem. Cheers!
    – Rey Mark
    Apr 23, 2022 at 11:35
  • 2
    Just remove the %u from the command line after installing the package Exec=/opt/viber/Viber Apr 26, 2022 at 5:33
  • 1
    Thank you very much. That saved my day! :D
    – FedKad
    May 3, 2022 at 11:21
  • 1
    Installing packages from other Ubuntu versions is a bad idea. This is a good way to get baffling system breakage sometime later. May 10, 2022 at 1:25
  • libssl1.1_1.1.1l-1ubuntu1.3_amd64.deb is no longer aviliable so you have to change both commands like wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.1l-1ubuntu1.5_amd64.deb and sudo dpkg -i libssl1.1_1.1.1l-1ubuntu1.5_amd64.deb Jul 3, 2022 at 13:58
7

How to install Viber in Ubuntu 22.04.1 LTS properly

(updated 11.01.23)

1. Optional Download Viber or skip if you already have viber.AppImage

wget -P ~/Downloads https://download.cdn.viber.com/desktop/Linux/viber.AppImage

2. Extract from AppImage & move to /opt

chmod +x ~/Downloads/viber.AppImage
~/Downloads/viber.AppImage --appimage-extract
sudo mv ~/squashfs-root /opt/viber

3. Download working libs & replace broken ones in /opt/viber/lib

export libsfilename="libssl1.1_1.1.1f-1ubuntu2_amd64.deb"
wget -P ~/Downloads http://security.ubuntu.com/ubuntu/pool/main/o/openssl/$libsfilename
dpkg -x ~/Downloads/$libsfilename ~/Downloads/viberlibs/
sudo rm /opt/viber/lib/libssl.so.* /opt/viber/lib/libcrypto.so.*
sudo cp ~/Downloads/viberlibs/usr/lib/x86_64-linux-gnu/lib* /opt/viber/lib/
rm ~/Downloads/$libsfilename

4. Move launcher to application folder & edit viber.desktop (point to actual Viber executable)

sudo cp /opt/viber/viber.desktop /usr/share/applications
sudo sed -i "s/Exec=.*/Exec=\/opt\/viber\/Viber/" /usr/share/applications/viber.desktop
sudo sed -i "s/Icon.*/Icon=\/opt\/viber\/viber\.png/" /usr/share/applications/viber.desktop

Profit! Open your launcher and there should be working Viber (if not logout & login)

4
  • I think that's a great workaround. Couple of mistakes though: 1) viber.appimage needs to get permission as an executable to extract 2) Correct move line is sudo mv ~/squashfs-root /opt/viber (not ~/Downloads/squash-root) 3) rm -rf line needs root permissions (sudo rm -rf ~/Downloads/viberlibs/) 4) Step 4 doesn't work, I logged out and back in, no Viber in the launcher. I bet we can fix that. Nonetheless, it works great from its original location (/opt/viber/Viber) May 22, 2022 at 19:58
  • There's something wrong with last step (sed -i). I tried to change it, but it's not my thing... All it does is that it changes the line to point to the correct executable location, right? Still, Viber app doesn't show up in launcher, don't know why May 22, 2022 at 20:26
  • 1
    Sorry @madzzohan, my bad! Only problem was the icon link :D Fixed it (Exec=/opt/viber/Viber and Icon=/opt/viber/viber.png) May 22, 2022 at 20:36
  • Let us continue this discussion in chat. May 22, 2022 at 21:26
5

The following sequence of commands worked for me to install a working viber client in a new Ubuntu 22.04 installation:

wget https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb
sudo apt install ./viber.deb
rm -rf viber.deb

# install the old, yet compatible with viber, openssl libs,
# to remove the "No connection" error at client startup
DEV=libssl-dev_1.1.1f-1ubuntu2_amd64.deb
NON_DEV=libssl1.1_1.1.1f-1ubuntu2_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/$DEV
wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/$NON_DEV
sudo apt install ./$DEV ./$NON_DEV
rm -rf $DEV $NON_DEV

Now it should be ready to go!

1

My problem was solved by installing the following packages libssl1.1_1.1.1f-1ubuntu2.12_amd64.deb, libssl-dev_1.1.1f-1ubuntu2.12_amd64.deb

0
1

I installed it using flatpak:

sudo apt install flatpak
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
flatpak install flathub com.viber.Viber
echo "flatpak run com.viber.Viber" | sudo tee /usr/local/bin/viber
sudo chmod +x /usr/local/bin/viber

Start viber with:

viber
0

Following up previous comments, case is closed.

I went with madzohan's solution for a while, but Viber's current version (18.2.0.2) seems to have solved the issue (and some others, too).

So, all you need to do is download latest Viber version and install.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .