Since about two years now I am trying to find a way to convert high quality mp3 files to m4a or aac files with a fixed bitrate 192k. Please don't suggest using another format - i thought this through as far as it goes.

The problem here is:

  • ffmpeg obvioulsy can't convert to a higher bitrate than 152k. Even when it says it does so the resulting files still have 152k instead of 192k.

  • ffmpeg also has/had a bug not writing the bitrate into the audio file tags which means when testing you have to calculate the bitrate manually by dividing the filesize by the length of the audio in seconds (resulting in 152k - see above)

  • choosing faac as converter gets me the same results

  • other programs don't work reliably (see this thread Howto convert audio files to *.m4a?)

I know that this is not an original new problem but I am wondering if there is still no way to convert with ubuntu/kubuntu 12.04 after a lot time passed and I can't find some of the bug issues mentioned in the other thread anymore.

So: Is there a solution after all?

3 Answers 3


I think I found the solution right here:


It's called format junkie and it converts to 192kbit m4a (aac) without problems. Check it out - it's a bit flashy but a really simple and yet powerful media converter for images, audios, videos and even iso-files!

Sorry for answering my own question, but for me I consider it solved. :-)

thx for reading, piedro


I don't know if it has the same bitrate bug as ffmpeg, but VLC has a useful file conversion option.

Choose Media > Convert / Save

Select your files using Add... then click Convert / Save

Select Audio - AAC (MP4) under the profile and then click the edit profile button next to it, then on the second tab there is a bit-rate pull down menu.

I don't have any files of the right quality to test it on but it's worth a try.

  • thx. while this works converting there's even more downsides: first it doesn't save any tags and so the file doesn't contain any information - neither on the track information nor on the bitrate after converting. then it doesn#t seem to be a fixed bitrate but a vbr. And last it's still 152k though i set it to 192k!
    – piedro
    May 21, 2012 at 18:37
  • I had a feeling that might be the case. Under Ubuntu VLC may even use the ffmpeg back-end for conversion and so you may be looking at the same bug in two different guises.
    – Slipstream
    May 27, 2012 at 12:53
  1. Install the package gnome-media-profiles, gstreamer0.10-plugins-bad-multiverse and soundconverter
  2. Launch the command (ALT+F2) gnome-audio-profiles-properties and create a new profile called AAC192. For "File extension" use m4a and in the field "GStreamer pipe", enter

    audio/x-raw-int,rate=44100,channels=2 ! faac ! bitrate=192 ! ffmux_mp4 AAC Profile

  3. Start Sound Converter, go to "Settings" and for "Format", choose GNOME Audio Profile. Now you can select AAC192

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.