2

I have laptop Acer spin 5 "Spin SP513-54N" and had ubutnu 21.10 installed on it. At first, the touch pad and touch screen were not working so I followed the instructions in this page and it fixed it: https://sciactive.com/2020/12/04/how-to-install-ubuntu-on-acer-spin-5-sp513-54n-for-the-perfect-linux-2-in-1/

sudo gedit /etc/default/grub
Add pci=nocrs to the end of the options for GRUB_CMDLINE_LINUX_DEFAULT. It should look something like this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nocrs"
sudo update-grub

Later when I upgraded to ubuntu 22.04, touch pad and touch screen stopped working again When ubuntu 22.04 starts up before applying GRUB fix, I get this error: enter image description here

Ubuntu starts fine but the touch is not working. But when I apply the fix, ubuntu 22.04 fails to start with this error: enter image description here

I tried every fix I could possible find online but nothing works. plz help me with this issue as the computer is not usable without touch pad

3
  • This is the reason I am staying on 20.10 - it's very unfortunate: quote: "Hans de Goede (j-w-r-degoede) wrote on 2022-05-13: #39 Sorry that it is taking so long to fix this. There have been several attempts at fixing this upstream already, but all of them had to be reverted/dropped because they were causing issues on other laptop models...." - more in the original bugreport bugs.launchpad.net/ubuntu/+source/linux/+bug/1884232
    – crysman
    May 17 at 11:18
  • It needs to be changed in kernel. However, it is still primarily the BIOS' fault, among others - community.acer.com/en/discussion/636073/… - but I doubt ACER would do anything about these :( So that's why it's more probable to fix via kernel update once the patch is upstream...
    – crysman
    May 17 at 11:26
  • Same problem here
    – Nathan B
    Nov 21 at 9:27

1 Answer 1

0

Upgrading the kernel to 5.18:

wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.18/amd64/linux-headers-5.18.0-051800-generic_5.18.0-051800.202205222030_amd64.deb
wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.18/amd64/linux-headers-5.18.0-051800_5.18.0-051800.202205222030_all.deb
wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.18/amd64/linux-modules-5.18.0-051800-generic_5.18.0-051800.202205222030_amd64.deb
wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.18/amd64/linux-image-unsigned-5.18.0-051800-generic_5.18.0-051800.202205222030_amd64.deb
sudo dpkg -i *.deb

Then everything works with pci=nocrs.

3
  • Are you sure upgrading to kernel v5.18 the parameter pci=nocrs works without any issue?
    – Harry
    May 30 at 13:05
  • It works for me on my Acer Spin 5 SP513-54N.
    – Rick Tu
    May 30 at 19:07
  • I got the following errors: 1- dpkg: dependency problems prevent configuration of linux-headers-5.18.0-051800-generic: linux-headers-5.18.0-051800-generic depends on libc6 (>= 2.34); however: Version of libc6:amd64 on system is 2.31-0ubuntu9.9. linux-headers-5.18.0-051800-generic depends on libssl3 (>= 3.0.0~~alpha1); however: Package libssl3 is not installed. 2- dpkg: error processing package linux-headers-5.18.0-051800-generic (--install): dependency problems - leaving unconfigured 3- Errors were encountered while processing: linux-headers-5.18.0-051800-generic Jun 5 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.