24

I may be an alien around here, but here's my problem: the speed limit on old Ubuntu releases (= before 11) was very very fast. It was really great for me.

Now, on Ubuntu 11, they may have thought: "who will ever want that speed? Nobody! So let's put the maximum speed to a lower limit".

It's so stupid that they tried to narrow down the speed to some other famous OS. If Linux is more powerful, why remove some of its power? I don't get that.

So is there any way to override that speed limit and get my keyboard as fast as it is on other previous versions?

  • You mean the repeat rate, when you hold down a key? – psusi May 21 '12 at 15:59
  • @mateo_salta kbdrate doesn't work at all = has no effect on my keyboard: sudo kbdrate -r 30.0 -d 1440 and sudo kbdrate -r 2.0 -d 10 have same effect = nothing. – Olivier Pons May 22 '12 at 6:56
  • @psusi You're right I've changed the title – Olivier Pons May 22 '12 at 6:57
  • There are two Ubuntu releases whose numbers start with 11--11.04 and 11.10. You may want to edit your question to clarify which one you are running. – Eliah Kagan May 23 '12 at 20:56
  • Both releases: 11.04 and 11.10 – Olivier Pons May 24 '12 at 15:38
14

Given that this issue hasn't been fixed yet, and can be very frustrating, I here's a workaround:

Initially I used xset r rate, but the problem with it is that it's not persistent after sleep/awake, and sometimes the desktop reverts to limited rate at random times (probably gnome settings daemon does something which causes reinforcing the settings).

I was uselessly changing my old gconf keyboard settings, only to discover that the setting has been migrated to gsettings. The value limit is hardcoded in the system settings application (gnome-control-center in file ./panels/keyboard/gnome-keyboard-panel.ui:877).

You can easily override it:

gsettings set org.gnome.settings-daemon.peripherals.keyboard repeat-interval 15
gsettings set org.gnome.settings-daemon.peripherals.keyboard delay 150

As long as you don't change your settings from the gui, this setting should be persistent.

  • This is a really good answer, and as soon as I can test it I'll verify if it works, and if so I'll check your answer as good. But I've reverted back to Ubuntu 10.04 which is far more stable, better, faster and friendlier than all other versions (from my point of view) – Olivier Pons Oct 22 '12 at 8:17
  • this worked great for me – Dave Cousineau Nov 12 '13 at 21:55
  • 1
    Ok your answer works but depends of the distributions. For me it was: gsettings set org.cinnamon.settings-daemon.peripherals.keyboard repeat-interval 20 and gsettings set org.cinnamon.settings-daemon.peripherals.keyboard delay 150 – Olivier Pons Dec 4 '14 at 15:10
  • 4
    No such key in Ubuntu 16.04 anymore. Anyone know how to do it in the new Ubuntu version?? – Valar Morghulis Nov 28 '16 at 17:26
  • 3
    current solution is in answer below from Erik Olofsson ... gsettings set org.gnome.desktop.peripherals.keyboard repeat-interval 17 – Scott Stensland Mar 13 '17 at 21:34
20

In Ubuntu 15.10 and later the settings have moved.

To get approximately 90 cps repeat rate and 150 ms delay:

gsettings set org.gnome.desktop.peripherals.keyboard delay 150
gsettings set org.gnome.desktop.peripherals.keyboard repeat-interval 11

At these high repeat rates I would recommend to stay as close to a multiple of your screen refresh rate as possible. This will help you stop at the wanted location as the movement is easier to follow.

If we take the default example of a 60 Hz display this works out to one of these repeat intervals:

30  cps = 1000/30  ≈ 33 ms (30.3  cps)
60  cps = 1000/60  ≈ 16 ms (62.5  cps)
90  cps = 1000/90  ≈ 11 ms (90.9  cps)
120 cps = 1000/120 ≈ 8  ms (125.0 cps)
  • 1
    thanks, this works for me. I cannot use the above ones include org.gnome.settings-daemon ones. – Valar Morghulis Nov 28 '16 at 17:37
  • 3
    This works on 16.04 – Scott Stensland Mar 13 '17 at 21:35
  • vote up this answer this is the right one for 16.06 LTS – Louis Jun 14 '17 at 7:38
  • Strangely neither the setting in the preferences panel nor this one had any effect. Only xset worked for me. Could there be any reason for that? – xji Nov 28 '17 at 13:10
  • Works in Ubuntu 18.04. I find 200/20 best combination for delay/repeat rate. – WinEunuuchs2Unix Apr 29 '18 at 17:46
14

You can temporarily override Ubuntu's max keyboard rate using the xset command if you're using GNOME 3 on Ubuntu > 10.04. Example:

xset r rate 220 160

You can also try adding (uncomenting) the following in /etc/kbd/config:

KEYBOARD_RATE="160"

KEYBOARD_DELAY="220"

Edit: corrected an inconsistency in the examples.

  • Hi, have you any idea on how to put set it at start so that it's set for every applications I may launch? Thank you – Olivier Pons Jan 27 '14 at 12:16
  • uncomment the following in /etc/kbd/config: KEYBOARD_RATE="220" KEYBOARD_DELAY="160" – jarederaj Mar 8 '14 at 17:03
  • Also see: linuxcommand.org/man_pages/kbdrate8.html – jarederaj Mar 8 '14 at 17:13
  • 1
    Isn't it 'r rate [delay [rate]]' meaning that in your example KEYBOARD_DELAY="220" KEYBOARDD_RATE="160"? – Rohit Banga Apr 10 '14 at 22:17
  • 3
    There's no file /etc/kbd/config and I don't think it's working when I create one. Ubuntu 16.10 – Nickolai Leschov Feb 3 '17 at 17:04
2

Go to System-> Preferences-> Keyboard, and adjust the Repeat Keys Speed slider to the far right. On later systems you access this control using the Unity Launcher's System Settings--the button with the wrench. The control panel is the same.

  • 1
    I presume that's the dialog box he's already referring to. – thomasrutter May 22 '12 at 23:13
  • @neon_overload, who is referring to what box where? There is no mention of a box in the question. – psusi May 22 '12 at 23:14
  • 2
    He says that the maximum speed Ubuntu is allowing him to set is too low. Unless I see otherwise I presume he's talking about the regular keyboard settings dialog in Ubuntu. – thomasrutter May 22 '12 at 23:15
  • @neon_overload, he doesn't mention setting anything anywhere, just that the speed is lower. – psusi May 22 '12 at 23:16
  • The control panel is the same, but the keyboard repeat rate is lower. – Olivier Pons May 24 '12 at 15:37
0

I don't think that the UI for this is especially intuitive but, I find it hard to believe that the available settings are not adequate for your needs.

On v3.26.2 at least, the closer you drag the bar to the left the faster the repeat is. This is equivalent to the following:

gsettings set org.gnome.desktop.peripherals.keyboard repeat-interval 0

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.