0

I need to re-set my default sample rate in Pulseaudio to 48000, it changed without warning a couple of weeks ago. when I enter the following line in terminal - sudo vi /etc/pulse/daemon.conf - I get the following message -

E325: ATTENTION Found a swap file by the name "/etc/pulse/.daemon.conf.swp" owned by: root dated: Thu Apr 07 13:20:35 2022 file name: /etc/pulse/daemon.conf modified: YES user name: root host name: kelvin-ThinkPad-T420 process ID: 8505 While opening file "/etc/pulse/daemon.conf" dated: Sat Nov 20 04:40:36 2021

I have tried - vim -r /etc/pulse/daemon.conf I have tried to delete the swap file I have pressed enter

Always I am presented with the config file but I am not allowed to edit it at all. Terminal gets stuck in a process which never ends and I have audio which runs 10% too slowly, any ideas?

1 Answer 1

0

In /etc/ you need grandet rights. Normally pulseaudio is running as user systemd.service. If you want to change something make it in your $HOME.

If the folder it is not present

mkdir $HOME/.config/pulse

Then you can simple cp the file in to your home

cp /etc/pulse/daemon.conf $HOME/.config/pulse/

and make your changes there.

To get rid of your file in /etc close any editor and

sudo rm /etc/pulse/.daemon.conf.sw

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .