1

I have a 160GB drive and a 2TB drive (both internal) on a HP xw8200 I have windows xp on the 160 GB drive. partitioned a /boot 1GB, 10GB swap, 100GB /, and a 400GB /home on the 2TB drive. Chose to install Ubuntu 12.04 alongside XP, but just before the installation was complete, error about grub not being able to install.

Tried boot-repair, but still cannot boot into Ubuntu. Pls. find details at http://paste.ubuntu.com/998508/

Your help would be greatly appreciated, Balu

3
  • can you tell us the device you are trying to install grub into is dynamic or basic? You can get this info by runningdiskmgmt.msc in windows. Or you can post a screenshot of disk management window. (the window opened by above command)
    – Web-E
    May 21, 2012 at 6:49
  • Why not try installing grub once again from live? May 21, 2012 at 7:01
  • Web-E: All my partitions are basic. Apparently I cannot post images since I'm a new user. But pls. find the image at [1]: i.sstatic.net/D7Grk.png harisibrahimkv: I've installed and reinstalled GRUB many times (trying on different partitions), but to no avail. Thanks, Balu
    – Balu
    May 27, 2012 at 21:17

2 Answers 2

1

I have the same problem trying to install Ubuntu 12.04 along side Windows 7 on a 2TB internal. I installed Windows 7, left 1TB for Ubuntu during the Windows 7 installation, but when I boot from the Ubuntu 12.04 CD there's no "install along side Windows 7" option, only "use entire disk" and "something else".

According to the disk manager in Windows 7, the layout of my Windows 7 partition is "simple", and the type is "basic".

Have noticed a number of posts from people experiencing the same problem, have yet to find any answers.

2
  • Scott: Do you know if this is not the case with Ubuntu 11.10? Pls. let me know so that I may try to put 11.10 Thanks, Balu
    – Balu
    May 27, 2012 at 21:18
  • The problem was due to the 2TB drive. Booting from the Ubuntu 12.04 CD into Ubuntu (instead of the installer) and then installing and running "FixParts" solved the problem: sourceforge.net/projects/gptfdisk/files/gptfdisk/0.8.4/… Jun 4, 2012 at 22:03
0

Your Ubuntu partition ends far from the start of the disk. Try this: http://ubuntuforums.org/showthread.php?t=1998257

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .