0

I have a ROG Strix G731G and I already downloaded and use the rogauracore from this repository https://github.com/wroberts/rogauracore.git.

I use the sudo rogauracore black mode and the lights are off and everything is ok.

It works fine when the laptop is on, but as soon as I enter suspension (sleep mode) the lights turn red and start moving (bleeding effect).

It's very annoying because I need the darkness to sleep and I don't want to completely shut down the computer.

Does somebody know how to make rogauracore work also in sleep mode? Or does anyone know a trick to keep the keyboards and lid lights off during sleep mode?

Thanks

Edit: I need to control the lights (turn them off) in suspend mode. I have Ubuntu 20.04. I tried OpenRGB but it doesn't work on my computer (when running I get an error and already tried these solutions ("One or more I2C/SMBus interfaces failed to initialize.") but it doesn't work). The only thing that works is rogauracore but this doesn't work in sleep mode.

7
  • 1
    Nothing OS related runs or can run when sleeping. If there's a away to avoid that behavior you will or won't find it in the firmware (UEFI). Apr 4 at 18:40
  • I often wonder; starting a computer from scratch takes less than a minute, why then use "sleep mode" with all the problems it seems to have? (Also a G731 here, no trouble whatsoever, starting anew each evening). Tip "OpenRGB".
    – Hannu
    Apr 4 at 19:36
  • @Hannu because I don't want to open all the windows again (not only chrome). Apr 11 at 13:46
  • Openrgb doesn't work on my computer Apr 11 at 15:33
  • NOTE: Many programs can be made start in sequence, e.g. at login, it may take a minute or so, but no need to manually click on each one.
    – Hannu
    Apr 11 at 20:05

2 Answers 2

0

Try using "OpenRGB" - https://openrgb.org/

Note: I don't use "sleep mode" so haven't verified it to be a remedy for related problems.


This typed at the $ prompt of a Shell/Terminal will display BIOS version and all that
(hit ENTER at the end):

for s in $(dmidecode --string 2>&1 | tail -n +4) ; \
do echo -en "$s: \t";sudo dmidecode --string $s ; done
6
  • OpenRGB doesn't work on my computer. Apr 11 at 15:33
  • Well, sorry to hear that. I believe there is no "standard" on how these extra (meant to be) "cream on the top" functions are communicating with the outside world. It works well enough on my Asus G731GU w BIOS G731GU.310, to the extent that I was able to disable "the blinking".
    – Hannu
    Apr 11 at 20:08
  • I tried suspending my Ubuntu 20.04.4 LTS; A slowly flashing power button.
    – Hannu
    Apr 11 at 21:03
  • do you disable the backlights even in sleep mode? Apr 12 at 21:02
  • This is the BIOS info American Megatrends Inc. bios-version: G731GV.307 bios-release-date: 09/24/2019 system-manufacturer: ASUSTeK COMPUTER INC. system-product-name: ROG Strix G731GV_G731GV system-version: 1.0 system-serial-number: K6NRCV015870234 system-uuid: 75b2f77c-e019-bb4b-859c-0bd37c1589b7 system-family: ROG Strix baseboard-manufacturer: ASUSTeK COMPUTER INC. baseboard-product-name: G731GV baseboard-version: 1.0 Apr 12 at 21:06
0

Boot into windows by selecting "windows boot manager" while booting up. Once signed in, press the rog button, which will bring you to what they call the "armoury crate". On the left, you'll see an icon that is a keyboard and a mouse, this icon is called "device" but it may be that if only shows "system", since that seems to be the only sub option (at least in my device). Select "lighting" at the top, and then "settings" to the right. The only options there for me are the toggles for sleep and awake. Toggle "sleep" off. Then just restart into Ubuntu.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.