I've been searching for a way to play Blu-ray using VLC on Ubuntu 12.04 64bit and all of them tell me that I've to somehow rip the disk into .mkv format then play it.

But today, I found a page with directions on how to play Blu-rays directly on VLC. I've already finished downloading and pasting the files it told me to do, But it didn't work for me. Then I found a page where someone had tried it and it worked for them. Does anyone know how they got it to work?

The page with the directions.
The page where it worked.

I also found this
Does anyone know what it is talking about? I've already downloaded lxBDplayer, but I encountered a problem when installing the lcbdaacs plugins. Are there any other ways to install the lxbdaacs plugin?

  • It may well be that the DVD you're trying to watch needs a different key - as I understand it, there's a continual battle between rights protectors and freedom fighters, with keys occationally recinded and subsequently leaked/found ;)
    – drevicko
    Jul 7, 2012 at 8:14

5 Answers 5


Here's what you can do, to start open a terminal window, you can do this through the Dash, or by keystroking "Ctrl + T". Afterwards, what you may want to do is copy and paste the following commands into terminal. You can also, if more comfortable, type them manually. You can copy one by one, or all at once, it doesn't matter. Remember, when in terminal the past command is "Ctrl + Shift + V" instead of "Ctrl + V".

sudo add-apt-repository ppa:n-muench/vlc
sudo apt-get update
sudo apt-get install libaacs0 libbluray-bdj libbluray1
sudo apt-get dist-upgrade

That will only get blu-ray to work in VLC. We now need aacs folders, and to download the keys. We just enter a couple more commands into terminal.

cd ~/
mkdir -p ~/.config/aacs/
cd ~/.config/aacs/ && wget http://vlc-bluray.whoknowsmy.name/files/KEYDB.cfg

You should be all set now, enjoy your blu-ray movies!

All information and alternative methods can be found here.

  • This didn't work for me. I get the error Blu-ray error: No valid processing key found in AACS config file. Your input can't be opened: VLC is unable to open the MRL 'bluray:///dev/sr0'. Check the log for details.. Are there updated instructions anywhere?
    – tmoore82
    Nov 14, 2015 at 3:08
  • For me works only install libaacs0, libbluray-bdj and libbluray1 and open with vlc player.
    – momo2047
    Dec 25, 2015 at 15:07
  • Thanks, worked as explained. This should be the accepted answer.
    – nerdoc
    Mar 26, 2017 at 19:43

The problem is, that there is currently no program or library like libdvdcss2 (which enables VLC or other programs to watch DVDs) for Blu-Rays.

You either can rip protected Blu-Rays with a program of you choice, or you have a look into MakeMKV.

Using MakeMKV - after kompiling it, which is fairly easy - enables you to do both (as far as I know). But watching the Blu-Rays without ripping them first means, you need to know, how to watch a stream with a program like VLC, because that is what they do. And you need to check first, which chapter of the disk you want to see - you need to specify the correct chapter in VLC, otherwise nothing happens! The rest (language selection and so on) works out-of-the-box. But be aware, that this is a) work in progress and b) limited for testing (Blu-Ray only).

  • Oh, ok. But isn't libaacs a library for Blu-rays? Because I found someone in a forum who got it to work for them.
    – Kevin
    May 23, 2012 at 0:59

So from what I'm finding I may have a solution. Can't promise this will work, but I don't think it can hurt to try.

First I'd recommend installing an updated version of libaacs0 and libbluray1 from the motumedia mplayer daily PPA, and VLC from Videolan Stable-daily PPA

sudo add-apt-repository ppa:motumedia/mplayer-daily
sudo add-apt-repository ppa:videolan/stable-daily
sudo apt-get update
sudo apt-get upgrade

Then install the two libraries.

sudo apt-get install libaacs0 libbluray1

Then you'll need to make the directory and download the file to it.

mkdir ~/.config/aacs
cd ~/.config/aacs
wget http://vlc-aacs.whoknowsmy.name/files/KEYDB.cfg

From the instructions on they want you to place libaacs.so.0 in /usr/lib or /usr/lib64

Where this one is installed to /usr/lib/x86_64-linux-gnu or /usr/lib/i386-linux-gnu

My thoughts is that would be a possible reason.

I would try this myself but unfortunately I do not have a Blu-Ray drive. So please let me know if it works.

  • This worked for me using VLC (sudo apt-get install vlc vlc-plugin-pulse). For the lazy amongst us, I've put these commands together in a bash script in this Github Gist. Cheers.
    – Big Rich
    Nov 21, 2012 at 22:30

blu-play is a script that will play your blu-rays (without ripping them first). It pipes MakeMKV into VLC.

See How to play Blu-Rays in Ubuntu Linux. The installation is automatic. You just have to copy and paste a few things into Terminal.

And here's the blu-play script.


The instructions in the first link have worked for me on OS X and Ubuntu.

OS X worked as described. But in Ubuntu, when trying to play a Blu-ray, VLC told me there was an error that could not be fixed.

My problem was that, since the /usr/lib64 directory didn't exist, I just put libaacs.so.0 in /usr/lib. Then it occurred to me, since I'm running 64-bit Ubuntu and 64-bit VLC, I should try creating the /usr/lib64 directory and putting the file in there. Voila, it worked!

Also, I have more luck if I tell Ubuntu to ignore the disc, or open it as a folder, then open VLC manually, and do File->Open Disc, with the checkbox for "Ignore DVD Menus" checked (yes, even on Blu-ray). This is opposed to having Ubuntu open VLC automatically when a Blu-ray is inserted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .