I use Mozilla Firefox 98.0.2 on Ubuntu 20.04 as my primary browser.

For some random unknown reason it has decided to stop loading my server's control panel website.

I have tested the control panel in two different browsers and it loads fine, but not in Firefox. I have tried every Firefox trick I know, but it simply refuses to load the control panel...

Note: Every other site on the internet loads, except the one I need.

Things I have tried:

1.) cleared cache & cookies

2.) flushed dns cache - about:networking#dns

3.) used “forget about this site”

4.) private browser window

5.) changed tabs

6.) Restarted FF in Troubleshoot Mode (no add-ons or plugins)

Absolutely, nothing seems to be able to convince Firefox to load the site. The only unique thing about the site is that it has a self-signed SSL certificate.

Any tips?

  • Can you share the address of the site to test it?
    – raj
    Mar 28, 2022 at 12:05
  • Do you have any addons installed? If you do, test with all addons disabled. Had a similar issue with a printer configuration webpage.
    – To Do
    Mar 28, 2022 at 14:35
  • @ToDo thanks for the tip... I just restarted FF in troubleshoot mode (no plugins), didn't help.. still can't load the site.
    – nightwatch
    Mar 28, 2022 at 14:52

2 Answers 2


What solved this problem for me was to use the "refresh" FF option under Help // Troubleshoot Mode.

My control panel now loads correctly in FF, but unfortunately, after the refresh, I realized that it doesn't save my passwords, so I will be re-entering logins for a while..

However FF did save my tabs and bookmarks, so the "refresh" wasn't super painful.

For anyone else, who attempts this... There is an option to export your logins, when you click your FF login email and "Manage Account".. which I discovered, one step too late.. whoops.

oh well.. still refuse to join the google chrome herd. FF forever!


I had the same issue with Linkedin. The problem was in my router. As soon as I changed the router everything started working as intended. The problem I found was an update was needed to the firmware on my old router. I had tech forum documentation, and there were several errors with length of packets and buffer overflow. The updated firmware partly fixed this.

  • Thanks for the feedback... there was actually a ISP company repair guy tweaking things around the time this problem started. So far I have only tested on my home network and on my neighbors wi-fi, which share a primary router upstream, that the repair guy tweaked.. Tomorrow, I will hit a cafe and see if that solves the problem.
    – nightwatch
    Mar 28, 2022 at 14:55
  • Got impatient... I did a complete FF refresh... which deleted my plugins addons and passwords.. but I got my 1 website back :-/ thanks for feedback
    – nightwatch
    Mar 28, 2022 at 15:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .