5

When logging in lubuntu 12.04, my background image always disappears, leaving the screen with color only and then I have to go to definitions and set the image in the background again.

I notice that this does not happen with low-resolution images, only with high ones, but also happens with images that fit my screen resolution (1280 X 720).

Any ideas on how to fix this?


The image remains at it's location, but on the desktop preferences, the pathway to the file location is lost and set to none.

  • No, the image remains at it's location, but on the desktop preferences, the pathway to the file location is lost and set to <none>. – Neptunno May 20 '12 at 19:27
  • 1
    did you fool around with the /etc/dconf/db/local.d/locks directory? (do you have that directory?). btw! Feel free to edit it into your question so we can delete the comments ;) – Rinzwind May 20 '12 at 19:43
  • 1
    what's the cut-off? Are images slightly greater than 1280x720 doing this? What about slightly smaller? Have you tried copying the background image to /usr/share/backgrounds (copy it as root) and loading it as background image for your desktop from there? – titaniumtux May 20 '12 at 19:44
  • 1
    The picture is present at the the log in screen, then after log in disappears. I can change it the manually in the Appearance menu, but this changes do not survive the next boot :( – EDi May 29 '12 at 16:28
  • 1
    Do you use any remote desktop tools such as XRDP or similar since these often try to remove backgrounds to speed things up, but they can tend to be buggy.. – agc93 May 31 '12 at 12:07
2

I had the same problem. When I login, I get a black screen as if the image has been deleted. Then I figured out that it was a permission issue. So I went into the permission tab, and changed Group, and Other permissions to Read and Write, and that fixed it.

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

gksudo nautilus

When it comes up navigate to /usr/share/backgroundsand change the permissions from the permission tab.

enter image description here

2

Maybe image's path didn't have the right permissions, try to move one to your Pictures directory and tell me if it still get lost on new sessions.

If that's the problem you could set the rigth permissions to your images's folder running:

gksu nautilus

and through the properties dialog set permissions for your user to read-whrite that directory, remember to press apply to enclosed files button.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.