I know that you're probably sick with this issue, but I promise you all that I searched for a solution for this annoying issue, but couldn't find a thing.

When I suspend my laptop, normally the power button keeps blinking, and then it should resume, in my case it won't, it seems as it's about to resume, then the laptop shuts down, then suddenly powers up, but with nothing. The screen stays black, and the HDD indicator won't blink.

I've a MSI VR601 laptop: - Intel Pentium Dual CPU T2370 (1.73 GHz) - 2 Gigabytes of RAM - 160 Gigabytes HDD - Intel Integrated Graphics (GM965)

I'm running Ubuntu 10.10 (GNOME, kernel 2.6.35-22), suspending never worked for me to be honest, on any Ubuntu edition, it just never worked. I once tried OpenSuse (KDE) and it worked flawlessly, but I'm an Ubuntu fan I can't swtich to anything else in the mean time.

I tried to install the s2ram thing, but when I try to run it, it says unsupported hardware.

I beg you to help me through this, I'm sick & tired of this issue.

Thanking you in advance.


I too had same issue with my netbook. By discussing it here at askubuntu I came to know that it was because of the ath9k wireless driver for my Atheros wireless LAN. I compiled and installed the drivers by following the answer for this question. You can find out which wlan card you have by executing this command sudo lshw | more.

  • I've a an Atheros wireless card as well, I'll follow the instructions that you provided and get back to you. Million thanks mate. Appreciate it. – Saifallah Nov 22 '10 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.