1

at the very beginning sound was working using the motherboard line out jack. A few days ago the motherboard line out jack went bad. The sound is awfully robotic and unintelligible. The jack on the case front panel gives no sound at all (I hadn't tried it before, because I was using the motherboard line out on the back).

Computer is 3 weeks old:

I've tried many things: pavucontrols, reloading/restarting alsa and pulseaudio, adding lines like options snd-hda-intel model=auto, installing graphics card driver but nothing seems to work.

A few additional info:

Ubuntu

$ lsb_release -a | grep Description
Description:    Ubuntu 20.04.4 LTS

Kernel

$ uname -a
Linux dodo 5.13.0-37-generic #42~20.04.1-Ubuntu SMP Tue Mar 15 15:44:28 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Mobo

$ sudo dmidecode -t 2 | grep "Manufacturer\|Product"
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: Z690 AORUS PRO

Audio

$ lspci -v | grep Audio
00:1f.3 Audio device: Intel Corporation Device 7ad0 (rev 11)
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)
    Subsystem: Gigabyte Technology Co., Ltd GP107GL High Definition Audio Controller

Graphics card

$ cat /proc/asound/card*/codec* | grep Codec
Codec: Nvidia GPU 80 HDMI/DP

Update: additional information

$ pactl list sinks
Sink #5
    State: SUSPENDED
    Name: alsa_output.usb-Generic_USB_Audio-00.analog-stereo
    Description: USB Audio Analog Stereo
    Driver: module-alsa-card.c
    Sample Specification: s16le 2ch 44100Hz
    Channel Map: front-left,front-right
    Owner Module: 26
    Mute: no
    Volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
            balance 0,00
    Base Volume: 65536 / 100% / 0,00 dB
    Monitor Source: alsa_output.usb-Generic_USB_Audio-00.analog-stereo.monitor
    Latency: 0 usec, configured 0 usec
    Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
    Properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "USB Audio"
        alsa.id = "USB Audio"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "2"
        alsa.card_name = "USB Audio"
        alsa.long_card_name = "Generic USB Audio at usb-0000:00:14.0-4, high speed"
        alsa.driver_name = "snd_usb_audio"
        device.bus_path = "pci-0000:00:14.0-usb-0:4:1.0"
        sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/sound/card2"
        udev.id = "usb-Generic_USB_Audio-00"
        device.bus = "usb"
        device.vendor.id = "0414"
        device.vendor.name = "Giga-Byte Technology Co., Ltd"
        device.product.id = "a012"
        device.product.name = "USB Audio"
        device.serial = "Generic_USB_Audio"
        device.string = "front:2"
        device.buffering.buffer_size = "352800"
        device.buffering.fragment_size = "176400"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analog Stereo"
        device.description = "USB Audio Analog Stereo"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-usb"
    Ports:
        analog-output-speaker: Speakers (priority: 10000, not available)
        analog-output-headphones: Headphones (priority: 9900, available)
    Active Port: analog-output-headphones
    Formats:
        pcm
$ pactl list cards
Card #0
    Name: alsa_card.pci-0000_01_00.1
    Driver: module-alsa-card.c
    Owner Module: 7
    Properties:
        alsa.card = "1"
        alsa.card_name = "HDA NVidia"
        alsa.long_card_name = "HDA NVidia at 0x53080000 irq 17"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:01:00.1"
        sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
        device.bus = "pci"
        device.vendor.id = "10de"
        device.vendor.name = "NVIDIA Corporation"
        device.product.id = "0fb9"
        device.product.name = "GP107GL High Definition Audio Controller"
        device.string = "1"
        device.description = "GP107GL High Definition Audio Controller"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    Profiles:
        output:hdmi-stereo: Digital Stereo (HDMI) Output (sinks: 1, sources: 0, priority: 5900, available: no)
        output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (sinks: 1, sources: 0, priority: 800, available: no)
        output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (sinks: 1, sources: 0, priority: 800, available: no)
        output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (sinks: 1, sources: 0, priority: 5700, available: no)
        output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (sinks: 1, sources: 0, priority: 600, available: no)
        output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (sinks: 1, sources: 0, priority: 600, available: no)
        output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (sinks: 1, sources: 0, priority: 5700, available: no)
        output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (sinks: 1, sources: 0, priority: 600, available: no)
        output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (sinks: 1, sources: 0, priority: 600, available: no)
        output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (sinks: 1, sources: 0, priority: 5700, available: no)
        output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (sinks: 1, sources: 0, priority: 600, available: no)
        output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (sinks: 1, sources: 0, priority: 600, available: no)
        output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (sinks: 1, sources: 0, priority: 5700, available: no)
        output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (sinks: 1, sources: 0, priority: 600, available: no)
        output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (sinks: 1, sources: 0, priority: 600, available: no)
        output:hdmi-stereo-extra5: Digital Stereo (HDMI 6) Output (sinks: 1, sources: 0, priority: 5700, available: no)
        output:hdmi-surround-extra5: Digital Surround 5.1 (HDMI 6) Output (sinks: 1, sources: 0, priority: 600, available: no)
        output:hdmi-surround71-extra5: Digital Surround 7.1 (HDMI 6) Output (sinks: 1, sources: 0, priority: 600, available: no)
        off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
    Active Profile: off
    Ports:
        hdmi-output-0: HDMI / DisplayPort (priority: 5900, latency offset: 0 usec, not available)
            Properties:
                device.icon_name = "video-display"
            Part of profile(s): output:hdmi-stereo, output:hdmi-surround, output:hdmi-surround71
        hdmi-output-1: HDMI / DisplayPort 2 (priority: 5800, latency offset: 0 usec, not available)
            Properties:
                device.icon_name = "video-display"
            Part of profile(s): output:hdmi-stereo-extra1, output:hdmi-surround-extra1, output:hdmi-surround71-extra1
        hdmi-output-2: HDMI / DisplayPort 3 (priority: 5700, latency offset: 0 usec, not available)
            Properties:
                device.icon_name = "video-display"
            Part of profile(s): output:hdmi-stereo-extra2, output:hdmi-surround-extra2, output:hdmi-surround71-extra2
        hdmi-output-3: HDMI / DisplayPort 4 (priority: 5600, latency offset: 0 usec, not available)
            Properties:
                device.icon_name = "video-display"
            Part of profile(s): output:hdmi-stereo-extra3, output:hdmi-surround-extra3, output:hdmi-surround71-extra3
        hdmi-output-4: HDMI / DisplayPort 5 (priority: 5500, latency offset: 0 usec, not available)
            Properties:
                device.icon_name = "video-display"
            Part of profile(s): output:hdmi-stereo-extra4, output:hdmi-surround-extra4, output:hdmi-surround71-extra4
        hdmi-output-5: HDMI / DisplayPort 6 (priority: 5400, latency offset: 0 usec, not available)
            Properties:
                device.icon_name = "video-display"
            Part of profile(s): output:hdmi-stereo-extra5, output:hdmi-surround-extra5, output:hdmi-surround71-extra5

Card #1
    Name: alsa_card.usb-Generic_USB_Audio-00
    Driver: module-alsa-card.c
    Owner Module: 26
    Properties:
        alsa.card = "2"
        alsa.card_name = "USB Audio"
        alsa.long_card_name = "Generic USB Audio at usb-0000:00:14.0-4, high speed"
        alsa.driver_name = "snd_usb_audio"
        device.bus_path = "pci-0000:00:14.0-usb-0:4:1.0"
        sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/sound/card2"
        udev.id = "usb-Generic_USB_Audio-00"
        device.bus = "usb"
        device.vendor.id = "0414"
        device.vendor.name = "Giga-Byte Technology Co., Ltd"
        device.product.id = "a012"
        device.product.name = "USB Audio"
        device.serial = "Generic_USB_Audio"
        device.string = "2"
        device.description = "USB Audio"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-usb"
    Profiles:
        input:analog-stereo: Analog Stereo Input (sinks: 0, sources: 1, priority: 65, available: no)
        input:iec958-stereo: Digital Stereo (IEC958) Input (sinks: 0, sources: 1, priority: 32823, available: yes)
        output:analog-stereo: Analog Stereo Output (sinks: 1, sources: 0, priority: 39268, available: yes)
        output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (sinks: 1, sources: 1, priority: 6565, available: yes)
        output:analog-stereo+input:iec958-stereo: Analog Stereo Output + Digital Stereo (IEC958) Input (sinks: 1, sources: 1, priority: 39323, available: yes)
        output:iec958-stereo: Digital Stereo (IEC958) Output (sinks: 1, sources: 0, priority: 38268, available: yes)
        output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 5565, available: yes)
        output:iec958-stereo+input:iec958-stereo: Digital Stereo Duplex (IEC958) (sinks: 1, sources: 1, priority: 38323, available: yes)
        off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
    Active Profile: output:analog-stereo+input:iec958-stereo
    Ports:
        analog-input-mic: Microphone (priority: 8700, latency offset: 0 usec, not available)
            Properties:
                device.icon_name = "audio-input-microphone"
            Part of profile(s): input:analog-stereo, output:analog-stereo+input:analog-stereo, output:iec958-stereo+input:analog-stereo
        analog-input-linein: Line In (priority: 8100, latency offset: 0 usec, not available)
            Part of profile(s): input:analog-stereo, output:analog-stereo+input:analog-stereo, output:iec958-stereo+input:analog-stereo
        iec958-stereo-input: Digital Input (S/PDIF) (priority: 0, latency offset: 0 usec)
            Part of profile(s): input:iec958-stereo, output:analog-stereo+input:iec958-stereo, output:iec958-stereo+input:iec958-stereo
        analog-output-speaker: Speakers (priority: 10000, latency offset: 0 usec, not available)
            Properties:
                device.icon_name = "audio-speakers"
            Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-stereo+input:iec958-stereo
        analog-output-headphones: Headphones (priority: 9900, latency offset: 0 usec, available)
            Properties:
                device.icon_name = "audio-headphones"
            Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-stereo+input:iec958-stereo
        iec958-stereo-output: Digital Output (S/PDIF) (priority: 0, latency offset: 0 usec)
            Part of profile(s): output:iec958-stereo, output:iec958-stereo+input:analog-stereo, output:iec958-stereo+input:iec958-stereo

Any help is greatly appreciated.

8
  • pactl list sinks will tell us, what outputs you have and pactl list cardswill tell us about your hardware. Copy the result into your question as you've done with the other information
    – kanehekili
    Mar 24 at 19:19
  • I just updated the question with the outputs of those commands. The headphones are connected to the case front panel jack.
    – rfc
    Mar 24 at 20:32
  • Tried an answer, but then I saw that you actually get a sound but somehow broken. So one must assume your Audio USB is defect. Try to get a monitor with speakers. Maybe your HDMI card still works
    – kanehekili
    Mar 24 at 21:35
  • I only get a horrible sound from the mother board jack. I get nothing from the case front panel jack. Shouldn't both work properly and independently of the graphics card output? I don't have a monitor with speakers...
    – rfc
    Mar 25 at 0:42
  • yes, both should work, hence my assumption that your hardware is broken. You might try any live USB Linux just to doublecheck
    – kanehekili
    Mar 25 at 7:33

3 Answers 3

2

One of the recent kernel updates seems to have introduced an issue with some audio devices. The solution is to modify PulseAudio’s default sample rate in daemon.conf.

Here’s how:

  1. Open Terminal (if it’s not already open)

  2. Open PulseAudio’s configuration file:

    sudo {editor of choice} /etc/pulse/daemon.conf
    

    Note: Be sure to replace {editor of choice} with your editor of choice.

  3. Find the line that looks like this:

    ; default-sample-rate = 44100
    

    Change it to this:

    default-sample-rate = 48000
    

    Note: The preceding ; is gone. This is important.

  4. Save the file and exit

  5. Restart PulseAudio:

    systemctl --user restart pulseaudio
    

This should resolve your audio problems 👍🏻

6
  • appreciated but the problem occurs from different place. I confirmed my USB DAC works with 20.04.3 installer LIVE session and 22.04 Beta LTS without noises. Only this 20.04 LTS updates has a devil inside. Apr 4 at 8:36
  • 1
    @SadaharuWakisaka Daemon != demon 😉
    – matigo
    Apr 4 at 8:43
  • sudo service noise-daemon stop yay. Apr 4 at 10:07
  • The motherboard sound jack is working. Thank you! However, the motherboard mic jack is still not working. Neither are the jacks on the front of the computer case (sound and mic). Any hints on those?
    – rfc
    Apr 4 at 18:13
  • It worked in my case! Thank you matigo!
    – rfc
    Apr 7 at 17:09
0

I am not sure this is an answer or not. I tried these things and the noise is gone. (From Arch Pulseaudio manual)

  1. Get rid of Timer based scheduler from sound server. Add tsched=0 to the udev module loader.

/etc/pulse/default.pa

load-module module-udev-detect tsched=0
  1. Enable Echo/Noise-Cancellation

    /etc/pulse/default.pa

Add this line

### Enable Echo/Noise-Cancellation load-module module-echo-cancel

Then kill pulseaudio and restart

pulseaudio -k
in case, you want to remove current settings mv .pulse .pulse_bak
pulseaudio --start

Perhaps this also was effective.
systemctl --user start pulseaudio.service

  1. USB DAC plugged into another port and restart system.

Note: I do not know which one was actually worked.

0

Downgrading to 5.13.0-35 fixed popping noise with XRUN on JACK from USB interface.

Related Bug: https://bugs.launchpad.net/ubuntu/+source/linux-signed-hwe-5.13/+bug/1966066

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Apr 19 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.