3

Possibly related items

The following question has the same exact behaviour as me. They suspected bad USB drives, but that is not my case as I have been trying 5 different ones I have laying around. They work on other laptops I own (older models).

What are my PC specs?

I have two laptops, same behaviour:

  • Asus Flow X13 (2021). Nvidia 3050, AMD Ryzen 9 5900HS, 16 gb ram
  • Asus Flow X13 (2021), Nvidia 3050Ti, AMD ryzen 9 5900HS, 32 gb ram

What happens?

  1. I plug in my newly created Ubuntu USB drive to my machine
  2. I boot from the USB drive, I select "Ubuntu" from the grub menu
  3. I get a blank screen. After a few seconds, the machine just reboots. Removing grub entries like "quiet", shows me text saying: Booting command list, but no more output.

What have I tried?

  • I have tried to modify the grub boot entry on the live USB by pressing e and then add items like nomodeset, modprobe.blacklist="nouveau", nouveau.modeset=0 - that in hope for it being GPU related. No luck.
  • I have tried both of my laptops, with same behaviour
  • I have downgraded my BIOS from v409 to V408. No luck.
  • Made 190% sure that Secure boot is off.
  • Tried 5 different USB drives
  • Been using different tools to flash the Ubuntu images; Rufus, Balena Etcher, YUMI, UUI
  • Been trying 20.04, 21.04 and 21.10 with same results.
  • Linux mint 20.3 boots without issues from Live USB.

My question

I am in a situation where I am lost on where to go next. I have tried to get all the information I possibly can. What is Ubuntu doing differently from Linux mint? How can I proceed to identify the issue?

4
  • 1
    408 is apparently also an issue for Ubuntu, Manjaro, and others. It will be interesting to see if someone knows the reason for Mint’s success, as that knowledge could be used to improve the installers (and boot loaders) in other distributions 🤔
    – matigo
    Mar 21 at 22:41
  • Same problem here. I tried to add debug to the kernel, and removed quiet splash. I got a single message Booting a command list on the screen before rebooting. Apr 10 at 13:25
  • Hi @MariusBjørnstad Can you try Kernel 5.15.18 or earlier and see if that allows you to boot? I've found that it works, but kernel 5.16 and 5.17 are not booting at all, absolutely no output debugging it either. I am currently on Fedora 35 using Kernel 5.15.18. You can also try to boot with flag: acpi=off - but that causes a lot of devices to not work such as mouse + keyboard on my model. I found similar issues here: askubuntu.com/questions/1138820/…
    – denNorske
    Apr 11 at 7:51
  • 1
    Hei @denNorske, I tried my Ubuntu 20.04 USB disk, and it worked! This uses kernel 5.8. After completing the install, it had installed kernel 5.13. I rebooted and, and kernel 5.13 had the same issue as above. I go into Advanced Options and boot 5.8, then it works. Apr 11 at 14:57

1 Answer 1

0

BIOS UPDATE 410 FIXES IT

Please check your model carefully (mine was GV301QE) and download the latest bios. 410 was dropped in the end of April 2022, and fixes the issue booting into newer kernels than 5.15.18 that previous BIOS versions couldn't.

https://www.asus.com/supportonly/ROG%20Flow%20X13%20GV301/HelpDesk_BIOS/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.